Support » Plugin: Yoast SEO » Yoast indexation status takes very long

  • Resolved Rafx



    I upgraded Yoast and it has feature to speed up website, but this takes very long, for now it takes 4 hours and is still going. It also shows: Object 87961 of 1794 processed. Should it not stop on 1794 object instead of going further?


    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Maybellyne


    Hello @rafx

    If you haven’t already, please try the following:

    • Install & activate the Yoast Test Helper plugin
    • Go to Tools -> Yoast Test
    • Hit the “Reset indexables & migrations” button
    • Delete your current Yoast SEO installation.
    • Update to Yoast SEO 14.0.4
    • Click the “Click here to speed up your site now” button.
    • Does this resolve the issue?

    Thread Starter Rafx


    Still no luck. Object 4510 of 1793 processed. And takes much time. Any other solutions?

    Plugin Support Md Mazedul Islam Khan


    We are sorry to hear that you’re still experiencing an issue with the Yoast SEO indexables analysis and we’d be happy to investigate the issue further for you.

    If you have already rested the indexables analysis tables by using the Yoast Test Helper plugin and the issue persists, can you please confirm whether you’re running a multilingual site using the 3rd party WPML plugin? If yes, you’ll need to select All languages from the top navigation bar and run the indexables analysis again.

    However, if you’re not running a multilingual site but the issue persist, we recommend you please try using the WP-CLI command for the indexables analysis to check whether this resolves the issue for you.

    Thread Starter Rafx


    Yes, I’m using WPLM, and did as you said with All languages, but the problem still persist. For now, I don’t use WP CLI, read that gives errors on your website. Any other options, or should I wait for you to repair this?

    Plugin Support benvaassen


    If that didn’t work for you, we’d recommend downgrading to 13.5 and waiting on our 14.1 release, which should include a fix to prevent this from happening. It should be released in a couple of days, so please hang in there for a little while!

    • This reply was modified 1 year, 4 months ago by benvaassen.
    Plugin Support Michael Tina



    Since you are using WPML, we would suggest reverting to version 13.5 of the Yoast SEO plugin until WPML puts out an update for compatibility with Yoast SEO version 14.

    You can revert back to the 13.5 version by downloading it and then performing a manual update of the plugin. You can download version 13.5 by performing the following steps:

    Click on the ‘Advanced View’ option (this is beneath the plugin version information near the bottom)
    ​Under ‘Previous Version’ select the version
    ​Click the ‘Download’ button.

    After downloading the 13.5 version of the plugin, you would next need to perform a manual update of the plugin. We have instructions on how to upgrade the plugin manually at the following link:

    You will need an FTP program such as FileZilla and your FTP details, which can be obtained from your host provider.

    Thread Starter Rafx


    Thank you for info, I’m using WP Rollback for reverting to earlier versions of plugins, so it’s faster then.

    Plugin Support Pcosta88



    We understand you have rolled back to an earlier version of Yoast as you have WPML. We will close this issue in order to keep the overview.

    If you are still experiencing the issue when you updated to Yoast v14.1 (expected sometime this week) and the newest WPML the forum guidelines, we ask that you please create separate topics for the issues you are experiencing.

    That way it’s easier to track issues and provide assistance on your specific concerns on your specific site. Plus, you will get your own alerts for the issue rather than someone else’s. You may make a new topic here:


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Yoast indexation status takes very long’ is closed to new replies.