Support » Plugin: Yoast SEO » Yoast has changed the slug on 4000+ blog posts

  • Resolved thoughton

    (@thoughton)


    So we are administering a large site with 4000+ blog posts.

    We installed Yoast SEO recently, and within a week we saw a huge increase in 404s. After investigating it seems that Yoast has changed the slugs on our 4000+ blog posts. It seems this is caused by the setting “Stop words in slugs” which is apparently enabled by default (?!). I might be wrong here, last week if you told me a ‘feature’ like this could be enabled by default I would have said you were insane.

    So now we are getting thousands of inbound visitors from Google that are ending up on our 404 page. We’ve 75,000 404s in the past week.

    I went into Yoast Advanced settings and disabled this ‘feature’. However our blog posts slugs are all still missing the ‘stop words’.

    I then went into WordPress permalinks and clicked ‘save’ hoping this would rebuild the slugs, but they are still missing the ‘stop words’.

    How do I restore our slugs to their previous state?

    • This topic was modified 10 months, 1 week ago by  thoughton.
    • This topic was modified 10 months, 1 week ago by  thoughton.
    • This topic was modified 10 months, 1 week ago by  thoughton.
    • This topic was modified 10 months, 1 week ago by  thoughton.
    • This topic was modified 10 months, 1 week ago by  thoughton.
    • This topic was modified 10 months, 1 week ago by  thoughton.
Viewing 4 replies - 1 through 4 (of 4 total)
  • I would immediately restore the site from backup, to the version right before the changes were implemented by Yoast where your slugs got screwed up.

    Additionally, I assume since you’re such a big site, you must have Dev and Test versions of the site set up? You should definitely be using these to test things before implementing on the live site, otherwise (as you’ve experienced) it could have dire consequences on your site and SEO.

    Good luck and god speed to you sir.

    We do have daily backups but we installed Yoast over a week ago.

    Is there no way to undo Yoast’s changes? I still can’t quite believe it’s changed all those slugs.

    Update: It isn’t quite as bad as we first feared!

    I may have spoken to soon when I accused Yoast changed the slugs on 4k posts. It now seems that it hasn’t changed every post, only a few hundred of them. It’s possible these few hundred have had SEO meta text added to them since last week, and saving the post changed the slug. We have around a dozen authors so it’s hard to be sure.

    I’m now fixing it using a plugin named ‘Regenerate Post Slug on Save’ which will revert the slug to the default whenever a post is updated. You can do this from the Quick Edit screen, so it’s a reasonably easy fix.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @thoughton We’re glad to hear that you were able to restore the slug of your posts and pages. By default, the Stop words in slugs option is enabled. However, if you think we shouldn’t enable it by default that could cause an issue, we’d welcome you to submit a feature request.

    You can submit the feature request at https://github.com/Yoast/wordpress-seo/issues/new. You will need an account to create one.

    Don’t forget to include the URL to this conversation in your feature request!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Yoast has changed the slug on 4000+ blog posts’ is closed to new replies.