Support » Theme: Twenty Twenty-Two » Yoast and twenty-twenty-two

  • Hi Roger,

    Thanks for your email! We understand that it can be frustrating when everything is confirmed, but you are still having issues. We’d be happy to explore the issue further.

    We reviewed the given example page https://www.rvbild.se/hugin-och-munin/ where the related links were being inserted via the Yoast SEO Related Links block.

    As we viewed the page, the related links look messed up due to the incorrect styling of the list items by your theme.

    We inspected those elements via browser Inspection Tools and by adding some custom CSS code into the browser editor, we experimented with it. See the attachment as it appears fine now.

    This indicates that our Yoast SEO-related block is outputting the relevant links on the given page though it is only the styling issue from the theme that is affecting the output to present it nicely.

    We highly recommend that you contact your theme developer for the fix.

    Just for your reference, this is the custom CSS code you might try adding to your theme CSS file.

    .wp-site-blocks .entry-content .wp-block-yoast-seo-related-links{ line-height: 50px; }
    and also some issues in navigation dropdown can’t read

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hi Roger!

    The default line-height in Twenty Twenty-two is 1.6. On your website, the default line-height has been changed to 0.

    Have you made any changes to the theme.json file or added any custom CSS?

    Thread Starter Roger Vikstrom

    (@roger-vikstrom)

    No I have just gone from twenty twenty -one to twenty twenty two
    ant there I have

    }
    .primary-navigation .primary-menu-container > ul > .menu-item > a + .sub-menu-toggle {
    display: none;
    }
    .envirabox-bg {background: #28303D !important;}
    .site-header {
    padding-bottom: 20px;
    }
    	.envira-gallery-captioned-data-polaroid {color: #000 !important;}

    OK
    *thinking*
    So we already know that Yoast SEO is not causing it; did you try disabling the other plugins one by one to see if they are changing the line height?

    Thread Starter Roger Vikstrom

    (@roger-vikstrom)

    yes I disabled all plugins except yoast.

    Thread Starter Roger Vikstrom

    (@roger-vikstrom)

    and it’s same with gallery menu dropdown

    I looked through the lightspeed CSS on the page you linked, the content of <style id="litespeed-ccss">.

    It includes CSS from Twenty Twenty-One. Did you switch from Twenty Twenty-One to Twenty Twenty-Two? Try clearing the lightspeed cache.

    If you are using Oderland for your hosting, try
    https://www.oderland.se/support/artikel/hur-hanterar-jag-litespeed-cache-via-cpanel

    (I do use Oderland myself, and I had to turn the lightspeed cache off, it caused more problems than the cache was worth)

    Thread Starter Roger Vikstrom

    (@roger-vikstrom)

    OK I flush the cache to lightspeed there was no changes unfortunately. So how to manage the <style id=”litespeed-ccss”>.? do I have to stop to use light speed ot could I change the css or erase it? What cashe plugin do you recommend ? I have also tried to inactivate Light speed no different. So I guess I have to delete the plugin or?
    Just for the moment I have to go back to use twenty twenty one.
    Regards
    Roger

    Thread Starter Roger Vikstrom

    (@roger-vikstrom)

    Hmmmmm seems to been forgotten

    Not at all. I read your reply from Saturday earlier today, but I’m ut of ideas.
    It sounds like the cache is not cleared. Deleting the plugin should not give a different result than deactivating it.

    You can still add the line height code to the Additional CSS field to try to override the CSS from the plugin.

    But the problem is not with the theme, maybe try the support channels for the cache plugin.

    Thread Starter Roger Vikstrom

    (@roger-vikstrom)

    You can still add the line height code to the Additional CSS field to try to override the CSS from the plugin.

    Where do I find it?

    ramf

    (@ramf)

    Hi @roger-vikstrom

    The way to add custom CSS is my going to the Dashboard => Appearance => Customize => Additional CSS.

    Any CSS code added there will reflect in your site.

    Regards,
    Ram

    Thread Starter Roger Vikstrom

    (@roger-vikstrom)

    so how is the code I should put in? I’m nor so good at CSS

    ramf

    (@ramf)

    Hi,
    I have to say that I don’t know.
    When you opened the post you added the information you got from Yoast – and they recommended adding this CSS code:

    .wp-site-blocks .entry-content .wp-block-yoast-seo-related-links{ line-height: 50px; }

    Maybe you should add it and see what will happen?

    Ram

    Thread Starter Roger Vikstrom

    (@roger-vikstrom)

    IS there a way to set CSS to all sides? now is like to throw out a bunch of playcard
    https://www.rvbild.se/smafaglar/
    https://www.rvbild.se/skogens-fyrbenta-djur/
    https://www.rvbild.se/om-naturfotograf-roger-vikstrom/
    all side is diffrent
    And to change space in the navigation meny and maybe size as well
    It looks okay in twenty twenty one but all settings is different in Twenty Twenty two I hav empty the cache in Litepeed an I manage to change .wp-site-blocks .entry-content .wp-block-yoast-seo-related-links{ line-height: 50px; }

    But not on all sides??? !! Https:// http://www.rvbild.se

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.