Support » Plugin: Yoast SEO » Yoast and posting/sharing on Twitter

  • Resolved mdugre

    (@mdugre)


    Hi All,

    I have a small issue when sharing a post on Twitter and I’m wondering if a) this is a Yoast problem and b) if someone can assist

    First off, let me just point out that I use Yoast Premium and in my settings, I have the Add Twitter card meta data set to enable. Also, on both my pages and posts (all of them) I use the wordpress variables %%sitename%%, %%title%%, etc…

    Now here’s my problem, when, on the WordPress backend, I click on the Yoast share tab and then the Twitter tab to look at the twitter preview, everything looks great BUT, UNLIKE when I share on Google+ and LinkedIn, when I share my posts on Twitter, my posts’ title comes up as %%sitename%% %%sep%% %%title%%.

    Has anyone else encountered this and what did you do to resolve the issue.

    Please advise and thanks in advance.

    Thanks,

    Marc
    P.S.: FYI, prior to my installing Yoast, I did not have this issue when sharing posts/pages. Don’t want to install another SEO plugin as I love Yoast so…

Viewing 1 replies (of 1 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi Marc,

    We ask that as a premium member you send us a support email to support@yoast.com. In that email we ask that you please provide a link to the url where the issue is happening. If you can also let us know what the exact Twitter title you are expecting it would be helpful for us to compare what is expected vs what is actually happening. A screenshot or a description of the Twitter preview on the backend would be helpful.

Viewing 1 replies (of 1 total)
  • The topic ‘Yoast and posting/sharing on Twitter’ is closed to new replies.