Support » Plugin: Yoast SEO » Yoast 7.0.2 (update) changes option for “remove the categories prefix”

  • Resolved endelab

    (@endelab)


    When you update Yoast to version 7.0.2, the value for “Search Appearance” > “Taxonomies” > “Category Urls” is not preserved: the value is always set to NOT “remove the categories prefix” (hold).

    This is very dangerous SEO side.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I have an error when remove category from slug in last update. Broken url and return 404

    @santi-navarro: I also had this problem.

    Same happened for one of our clients website that broke internal linking. For anyone needing a solution, here are some https://premium.wpmudev.org/blog/removing-category-base-urls-wordpress/ I went with “Another possibility” because first option in that post still relies on some plugin, yet second one is more “core WP solution” that I doubt will be removed so freely how it’s done with plugins. Tho it might not work for sub-categories

    For the error 404 issue, after changing the setup back to “remove category”, go to WordPress permalinks settings and save the configuration (without actually changing any option).
    This fixed the 404 errors for me.

    Tino

    (@dinerobits)

    Effectively lolobu, updating the permanent links is fixed. Thank you very much.

    Afterwards, there is an error in bread crumbs. The show – hide blog options are upside down. If you put hide you can see, and if you put on display it is not seen.

    • This reply was modified 1 year, 3 months ago by  Tino.

    @lolobu thank you so much man you save me… this update is not good at all

    Thank you for help!

    Plugin Support MariusG

    (@marius_codeinwp)

    Thank you @lolobu for sharing the solution.

    The issue where settings such as removing category not being migrated properly from the old versions should be fixed in Yoast SEO 7.0.3.

    @dinerobits Thank you for bringing this issue to our attention. A bug report is already open with our development team here: https://github.com/Yoast/wordpress-seo/issues/9174.

    Too bad, I am very disappointed for that. I had many keywords in the top 3 and now they’re lost.

    Go back to Yoast 6.3.1 – that one works.
    No version 7 works, even 7.9.1 fails – it shows a blank page, even on a new installation.
    I’m amazed this has not been found and fixed yet.

    1. Install Yoast SEO
    2. Set Search Appearance -> Taxonomies -> Remove Category URLs
    3. Save

    Go to https://domain.com/uncategorized (or any category with posts)

    This gives a blank page

    I even tried saving permalinks, but it didn’t help.

    Do the above with Yoast 6.3.1 and it works.

    Q.E.D.

    PhilEsq

    (@philesq)

    What is the recommended way to link to posts, using the category in the URL or not?

    I have been going crazy linking to posts. I had been linking to posts without using the category and without a 404 error. At some point, I noticed that the posts resulted in a 404 error so I changed the URLs to include the category. Sometime later, I found that I did not need the category in the URL again. Just now, I linked to a new post without the category and got a 404 error.

    I posted my problem in the WordPress forum and someone recommended:
    “Go to Settings ยป Permalinks, and simply click on Save Changes button. This will update your permalinks settings and flush rewrite rules. In most cases, this solution fixes the WordPress posts 404 error. However, if it does not work for you, then you probably need to update your .htaccess file manually or just watch it”

    I did that and it worked but I am afraid that if I link to posts without the category in the URL, I will periodically have 404 errors. Unfortunately, I think I will have to go through all my pages and look for links to posts without the category URL. This is going to be a major headache.

    This is the link with the category in the URL which gave me a 404 error again when I linked to the post without “equipment” in the URL:
    https://newyorkmotorcycleaccidentlawyer.com/can-i-use-under-glow-lights

    This URL worked. After clicking on the Save Changes button in Permalinks, the page now resolves to the URL without the category in the URL:
    https://newyorkmotorcycleaccidentlawyer.com/equipment/can-i-use-under-glow-lights

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Yoast 7.0.2 (update) changes option for “remove the categories prefix”’ is closed to new replies.