Support » Plugin: Yoast SEO » Yoast 15.8 kills existing theme breadcrumb

  • Resolved The-Dude

    (@the-dude-1)


    Hi Yoast-Team,

    thx for another buggy release. ๐Ÿ™

    After i’ve installed yoast 15.8 Premium my theme bread crumb was gone. Although i haven’t activated the yoast breadcrumb. And btw i don’t need this feature.

    Please fix this bug imediatly.

    Regards

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @the-dude-1,

    Sorry to hear that the changes aren’t working for your site. ๐Ÿ˜ž

    If you’d like to deactivate the Yoast breadcrumbs, you can disable them by going to SEO > Search Appearance > Breadcrumbs. You can set “Enable Breadcrumbs for your theme” to “Disabled”. Does that fix the issue?

    If not, can you give us more details about which theme you’re using and how you’ve added those breadcrumbs?

    iNtEnSePL

    (@intensepl)

    I second this. I use Ronneby theme which has breadcrumbs. When I install Yoast SEO two things can happen:
    1. When breadcrumbs are disabled in Yoast plugin – they dissappear altogether from webpage (even thou they are enabled in Ronneby theme).
    2. When breadcrumbs are enabled in Yoast plugin – they appear on the webpage, but look like garbage and are displaced (contrary to Ronneby breadcrumbs).

    Right now I have two options – forget about breadcrumbs or disable Youast SEO plugin. Both options are bad. Please resolve the issue
    1. Disabling breadcrumbs let’s the theme (i.e. Ronneby) handle breadcrumbs – Yoast doesn’t interfere
    AND
    2. Enabling breadcrumbs keeps them looking at lease the same as in theme.

    If you want access to my website to check it out – just let me know.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @intensepl According to the forum guidelines, you’ll need to open a new topic instead of replying to an existing post. That way, it’s easier to track issues and provide assistance without alerting someone else for your problems and debugging, when they don’t need it.

    iNtEnSePL

    (@intensepl)

    Just fix it and don’t teach me pls…

    Thread Starter The-Dude

    (@the-dude-1)

    @priscillamc Please read my post attentive again, then you’ll see, that your standard answer doesn’t make sense.
    I have only one additional info: My theme is the smartmag theme.

    iNtEnSePL

    (@intensepl)

    I managed to restyle Yoast breadcrumbs with CSS myself (and learn how to do this) before getting any productive answer… Way to go support.

    btw. The issue with disabling ALL breadcrumbs systemwide by Yoast is still a thing / bug.
    It’s exactly what I encountered – just like The-Dude did. So don’t ask me please to start a new topic just to say, that I have the same issue…

    • This reply was modified 3 months ago by iNtEnSePL.
    • This reply was modified 3 months ago by iNtEnSePL.
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @intensepl we’d be more than happy to investigate the issue further if it’s really an issue specific to us. Are you experiencing the same issue that you’d like us to investigate for you? If so, you’ll surely need to open a new topic.

    As mentioned, it’s a rule of this public forum and that we all are abiding by. However, if you don’t wish to let us investigate the issue further for you but you want to assist @the-dude-1, that’s completely fine. You won’t need to open a new topic then.

    Have an excellent rest of your day!

    Thread Starter The-Dude

    (@the-dude-1)

    Hello? Any solution in sight?

    all they do is tell people how to behave on forums, not help
    … based on EXPERIENCE (read above)

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @the-dude-1

    You’ve mentioned that you’ve installed Yoast SEO Premium v15.8. Do you have an active subscription of the Yoast SEO Premium plugin? If so, please do contact us directly so we can take a better look at this and provide support — https://yoast.com/help/support/#premium

    @intensepl we’re simply following the forum rules here on WordPress.org. Each website has lots of different plugins, themes, and each set-up is unique and totally different, and although the error could be similar, it could be caused by a totally different combination of plugins and themes. We hope you understand why we are requesting to create a separate forum topic. We’re not here to tell people how to behave, we just want to make sure we can provide the proper support, which also includes following the forum guidelines.

    Thread Starter The-Dude

    (@the-dude-1)

    Problem solved. ๐Ÿ™‚

    It was an strange interaction between installing yoast 15.8.2. and my theme. Means, that under certain circumstances (like yoast-update) one of the theme-plugins deactivates itself. In this special case and as a result, the breadcrumb navigation disappears.

    I’ve activated the theme-plugin and the breadcrumb appears. ๐Ÿ™‚

    You have to come up with that first … ๐Ÿคจ

    • This reply was modified 2 months, 3 weeks ago by The-Dude.

    The-Dude, That means, that Yoast deactivated theme functionality, not the other way around. I assume that you have different theme than I and the same happens (I won’t check your solution, as changing theme back and forth means I have to re-pin menu, adjust all widgets on the website etc.). The issue is in Yoast. If Beadcrumbs are disabled, the plugin shouldn’t “touch” anything, even on update, re-enabling etc.

    Great to hear that you found a solution for yourself. So did I (in different way).
    But bot our solutions are NOT a universal solution to the issue Yoast brought.

    And still, we are writing, and developer asks – are you premium?, if not, just use our free plugin with bugs.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.