Support » Plugin: Yoast SEO » Yoast 14.9 : PHP Fatal error: Allowed memory size

  • Resolved fabiencharrasse

    (@fabiencharrasse)


    Hello,

    I’m getting 500 errors on the pages (only post type = page, excluding homepage, blog page, CPT, taxonomy and term)
    I restarted the update process several times by doing the updates one by one and the error 500 is triggered just after updating Yoast (or after deactivation / reactivation of Yoast).

    Error logs don’t seem to help:

    [25-Sep-2020 14:14:09 UTC] PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 32768 bytes) in /home/xxx/public_html/xxx/wp-content/themes/vinci/builder/top-banner.php on line 1
    
    [25-Sep-2020 14:14:09 UTC] PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 262144 bytes) in /home/xxx/public_html/xxx/wp-includes/pomo/entry.php on line 89
    
    [25-Sep-2020 14:14:09 UTC] PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 32768 bytes) in Unknown on line 0

    This errors also appears :

    [25-Sep-2020 14:31:12 UTC] PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 53248 bytes) in /home/xxx/public_html/xxx/wp-includes/functions.php on line 4669
    
    [25-Sep-2020 14:34:51 UTC] PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 262144 bytes) in /home/xxx/public_html/xxx/wp-includes/wp-db.php on line 2131

    The file top-banner.php only contains a php tag open. Strange thing: if I empty this file and refresh the page, it displays without error but without the contents of the file. If I then put back the original content of my file and refresh the page, the page loads without problem. The “top-banner.php” file is loaded on all the pages and I have to do this manipulation individually on all the pages to avoid having a 500 error.

    I think there is an infinite loop somewhere in the Yoast update that is filling up memory.

    Hope it helps

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Suwash Kunwar

    (@suascat_wp)

    Hi @fabiencharrasse,

    We’re sorry that you are experiencing problems that might be caused by our plugin!

    Just to be sure, we would like to rule out any plugin or theme conflicts that may occur. The fastest way to do this is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Nineteen

    Test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin allows you to run a conflict check without affecting normal visitors to your site.

    As we can imagine that you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

    Thread Starter fabiencharrasse

    (@fabiencharrasse)

    Hello, sorry for the late reply.

    I just had the problem a second time while updating a site with a totally different theme. The problem is actually with this feature: https://yoast.com/help/why-does-yoast-seo-ask-to-index-a-sites-seo-data/
    Both sites have gone from a version of Yoast below 14 to the latest version.
    The notification asking me to index my pages didn’t appear immediately on the first site where I got the error, so I didn’t get it right away. As long as the indexing is not done, some pages actually fall with the errors previously reported. Once the indexing is done, the errors disappear.

    Thanks.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We can see how those errors would give you pause for concern. However, we think this is likely an issue. We would like some more information to help us rule out or in some things.

    1. We had another recent release. Can you confirm you are using the most recent Yoast SEO, v15.0? If you update, does the issue resolve?

    2. Are all your non-Yoast plugins and themes also updated?

    3. Can you confirm you are using WordPress 5.5.1? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/.

    4. Can you confirm your server has all the right requirements?  If you are not sure, speak to your host provider. They may need to increase the PHP memory. This guide explains more: https://kb.yoast.com/kb/plugin-requirements/.

    5. Is the error happening only on Pages? If you go to the Pages-All Pages, view is it also happening there?

    6. If it only happens on pages, how many pages does the site have? 10? 100? 10,000?

    7. How much content is on the pages? 100 words? 1000 words? 10,000 words?

    8. Did you use a pagebuilder to make the content? If so, are the pages constructed using 100s of different modules or just a couple like less than 10 or so?

    Thread Starter fabiencharrasse

    (@fabiencharrasse)

    To provide more details, I am a developer within an agency and the theme of the two sites is for each of them a variation of our basic theme. We have our own theme, creating from scratch and that we maintain and evolve for our clients for several years.

    1. The problem remains the same on version 14.9 and version 15.
    2. Yes.
    3. Yes.
    4. Yes.
    5. No display problem on the administration, only on the pages (excluding home page and blog page).
    6. 45 for the first, 25 for the second.
    7. It is rather variable but I would say on average between 500 and 1000.
    8. We use ACF to generate gutenberg blocks and we manage their display specifically. Only our custom blocks are available in the editor, the basic ones are disabled. There are on average 20-30 active plugins.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    This is an issue. Thank you for bringing this issue to our attention. We apologize for the trouble you are experiencing with our plugin. An issue report is currently open with our development team for this issue. We can’t say when we will have a resolution only that they are aware of the issue and are working on a fix.

    In the meantime, we suggest signing up for our newsletter as that is where we will announce product changes and updates. You may sign-up for it here https://yoast.com/ by scrolling towards the bottom to complete the sign-up field.

    @pcosta88,

    Thank you! We look forward to your fix. The sooner, the better since websites — as reported by many Yoast users in this forum — are “crashing.”

    Have a safe, productive week.

    Cheers!

    Thread Starter fabiencharrasse

    (@fabiencharrasse)

    @jetxpert

    A quick and easy way to solve the problem is to run the indexing process.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    As we have identified it as an issue we will close this in order to keep the overview. We are not closing the issue (as it is still open) just this specific topic as a resolution has been identified (it is an issue that we are aware of and are actively working on a fix).

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Yoast 14.9 : PHP Fatal error: Allowed memory size’ is closed to new replies.