Support » Plugin: Yoast SEO » YOAST 14.0 Cannot complete indexation process

  • Resolved frafor

    (@frafor)


    Hi there, I’ve already read your post about the huge changes in 14.x so I’m very excited about the new stuff you put in there.

    I’ve just updated some websites, all with the same set up: WP latest + WPML latest + SiteOrigin Page Builder + SO Widgets Bundle

    Two websites unfortunately are not able to complete the indexation process.

    It keeps going as the screenshot below.

    https://imgur.com/a/hnKZywm

    On the next run, I get less indexable, but it still goes on beyond infinity like Buzz Lightyear would say:

    https://imgur.com/a/ZQvFWj9

    Now this website is stuck at 46 items left, if I close the window it says there’s been issues indexing content. Another one I have is stuck at 1 item left, if I close the window it says the process went OK (the it still asks for indexing stuff on page refresh)

    In the console log i can see a lot of empty XHR requests/replies with empty nested objects:

    https://imgur.com/a/yn5oiD7

    Hope screens help.

Viewing 15 replies - 16 through 30 (of 30 total)
  • liberalcastilla

    (@liberalcastilla)

    He has not solved it for me either. It begins to index but it stops shortly.

    mimo1234

    (@mimocama)

    Hi,

    facing the same issue w/ latest 14.0.4, 43 items left. In my case, I noticed that table ‘yoast_indexable’ is filling up with the same entries while indexing is running. The same permalinks to product categories are added over and over again. Can see the number of rows increasing…

    select count(*) from wcyoast_indexable where permalink like ‘<my-product-category>’;
    4831
    4842

    Looks that something is running in a loop there? Did anyone notice the same?
    Hope this helps.
    Cheers

    studioavanti

    (@studioavanti)

    Same issue with Yoast 14.0.4, the number of indexed objects exceeds the total and it seems to increase infinitely.
    To be mentioned :
    – The problematic site runs WPML
    – Yoast 14.0.4 indexing process succeeded on another site without WPML

    reivilo

    (@reivilo)

    Same problem here on multiple sites. On a few sites no problem. No difference or pattern in problems found between sites with or without problem.

    Errors in JavaScript Console:

    wp-seo-indexation-1404.js?ver=14.0.4:1 GET https://mydomain.tld/wp-json/yoast/v1/indexation/posts/ 404 (Not Found)
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    tryCatch @ wp-polyfill.min.js?ver=7.4.4:1
    invoke @ wp-polyfill.min.js?ver=7.4.4:1
    t.<computed> @ wp-polyfill.min.js?ver=7.4.4:1
    r @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    tryCatch @ wp-polyfill.min.js?ver=7.4.4:1
    invoke @ wp-polyfill.min.js?ver=7.4.4:1
    t.<computed> @ wp-polyfill.min.js?ver=7.4.4:1
    r @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    tryCatch @ wp-polyfill.min.js?ver=7.4.4:1
    invoke @ wp-polyfill.min.js?ver=7.4.4:1
    t.<computed> @ wp-polyfill.min.js?ver=7.4.4:1
    r @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    dispatch @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=803c74bfb13fd0af6b3efa41a364d180:3
    r.handle @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=803c74bfb13fd0af6b3efa41a364d180:3
    wp-seo-indexation-1404.js?ver=14.0.4:1 TypeError: Cannot read property ‘length’ of undefined
    at wp-seo-indexation-1404.js?ver=14.0.4:1
    at tryCatch (wp-polyfill.min.js?ver=7.4.4:1)
    at Generator.invoke [as _invoke] (wp-polyfill.min.js?ver=7.4.4:1)
    at Generator.t.<computed> [as next] (wp-polyfill.min.js?ver=7.4.4:1)
    at r (wp-seo-indexation-1404.js?ver=14.0.4:1)
    at wp-seo-indexation-1404.js?ver=14.0.4:1
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    Promise.catch (async)
    (anonymous) @ wp-seo-indexation-1404.js?ver=14.0.4:1
    dispatch @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=803c74bfb13fd0af6b3efa41a364d180:3
    r.handle @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=803c74bfb13fd0af6b3efa41a364d180:3

    rsmith4321

    (@rsmith4321)

    The indexing finished on both my sites successfully with 14.0.4. But then, a couple of days later, the “click here to speed up your site” appeared again and the whole indexing started over. Again, this is after I had already completed the indexing on version 14.0.4, it then did it a second time.

    volneanschi

    (@volneanschi)

    Not for me, also @devnihil. CLI also being stuck on 100%

    Site with WPML

    • This reply was modified 10 months ago by volneanschi.
    Plugin Support devnihil

    (@devnihil)

    @torstensbuechereckede Can you please try the following?:

      1. Install & activate the Yoast Test Helper plugin
      2. Go to Tools -> Yoast Test
      3. Hit the “Reset indexables & migrations” button
      4. Delete your current Yoast SEO installation.
      5. Reinstall Yoast SEO 14.0.4.
      6. Click the “Click here to speed up your site now” button.
    studioavanti

    (@studioavanti)

    Hi,

    Thanks for the instructions.
    I tried, unfortunately it doesn’t solve the issue.
    The progress bar fills up completely, then the number of treated objects increases beyond the total objects number, e.g.:

    4206 objects treated on 2636

    reivilo

    (@reivilo)

    After following these instructions I still get the same error ‘Something went wrong while optimizing the SEO data of your site. Please try again later.’

    Plugin Support devnihil

    (@devnihil)

    @frafor If you are using WPML, we would suggest reverting to version 13.5 of the Yoast SEO plugin until WPML puts out an update for compatibility with Yoast SEO version 14.

    You can revert back to the 13.5 version by downloading it and then performing a manual update of the plugin. You can download version 13.5 by performing the following steps:

    After downloading the 13.5 version of the plugin, you would next need to perform a manual update of the plugin. We have instructions on how to upgrade the plugin manually at the following link: https://kb.yoast.com/kb/how-can-i-update-my-free-plugin/#ftp. You will need an FTP program such as FileZilla and your FTP details, which can be obtained from your host provider.

    Thread Starter frafor

    (@frafor)

    Hi @devnihil sorry if I couldn’t follow the topic. Yes I thought it was a WPML related issue because I didn’t have problems where I use Polylang. Will wait for updates from the WPML team. Thanks!

    Plugin Support Pcosta88

    (@pcosta88)

    @amirzwp @liberalcastilla @jordh @rsmith4321 @carmano @studioavanti @torstensbuechereckede @volneanschi

    If you are using WPML please revert to 13.5 of Yoast SEO until WPML puts out an update for compatibility with Yoast SEO version 14.

    You can revert back to the 13.5 version by downloading it and then performing a manual update of the plugin. You can download version 13.5 by performing the following steps:

    –​Visit https://wordpress.org/plugins/wordpress-seo/advanced/
    –Click on the ‘Advanced View’ option (this is beneath the plugin version information near the bottom)
    –​Under ‘Previous Version’ select the version
    ​–Click the ‘Download’ button.

    After downloading the 13.5 version of the plugin, you would next need to perform a manual update of the plugin. We have instructions on how to upgrade the plugin manually at the following link: https://kb.yoast.com/kb/how-can-i-update-my-free-plugin/#ftp.

    You will need an FTP program such as FileZilla and your FTP details, which can be obtained from your host provider.

    If you do not have WPML as per the forum guidelines, we ask that you please create separate topics for the issues you are experiencing.

    That way it’s easier to track issues and provide assistance on your specific concerns on your specific site. Plus, you will get your own alerts for the issue rather than someone else’s. You may make a new topic here: https://wordpress.org/support/plugin/wordpress-seo/#new-post.

    Thanks!

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

    Hi,

    You could have wait for WPML Yoast SEO Multilingual version 1.2.0 before closing this ticket 😉
    Anyway, this new release has solved my issue:
    https://wpml.org/compatibility/2020/07/yoast-seo-multilingual-1-2-0-improved-compatibility-with-yoasts-indexables-feature/

    @devnihil we are not using WPML and still experiencing this issue with Yoast SEO 15.3. I have also tried resetting via the Test plugin but same error occurs during the third call to /wp-json/yoast/v1/link-indexing/posts, nothing is returned from the response and then the error shows.

    EDIT: disregard. The Organization logo setting was filled in with an incredibly long string ending in thousands of “&”. I don’t know how it happened but it was causing the memory exhaustion.

    • This reply was modified 3 months, 1 week ago by Corey.
Viewing 15 replies - 16 through 30 (of 30 total)
  • You must be logged in to reply to this topic.