Support » Plugin: Yoast SEO » YOAST 14.0 Cannot complete indexation process

  • Resolved frafor

    (@frafor)


    Hi there, I’ve already read your post about the huge changes in 14.x so I’m very excited about the new stuff you put in there.

    I’ve just updated some websites, all with the same set up: WP latest + WPML latest + SiteOrigin Page Builder + SO Widgets Bundle

    Two websites unfortunately are not able to complete the indexation process.

    It keeps going as the screenshot below.

    https://imgur.com/a/hnKZywm

    On the next run, I get less indexable, but it still goes on beyond infinity like Buzz Lightyear would say:

    https://imgur.com/a/ZQvFWj9

    Now this website is stuck at 46 items left, if I close the window it says there’s been issues indexing content. Another one I have is stuck at 1 item left, if I close the window it says the process went OK (the it still asks for indexing stuff on page refresh)

    In the console log i can see a lot of empty XHR requests/replies with empty nested objects:

    https://imgur.com/a/yn5oiD7

    Hope screens help.

Viewing 15 replies - 1 through 15 (of 30 total)
  • Thread Starter frafor

    (@frafor)

    (btw as u can see there’s an issue with the popup too as it shows an undefined title! but i guess it’s a minor bug.)

    I got the same issue:

    We can’t precess the “Speeding up your site”-button.

    Following Error appears: Something went wrong while optimizing the SEO data of your site. Please try again later.

    WP-Debug:
    Fatal error: Uncaught PDOException: SQLSTATE[HY000]: General error: 1366 Incorrect string value: ‘\xF0\x9F\x97\xB8 w…’ for column ‘description’ at row 1 in /home/customer/www/paastoa.com/public_html/wp-content/plugins/wordpress-seo-premium/vendor_prefixed/j4mie/idiorm/idiorm.php:464 Stack trace: #0 /home/customer/www/paastoa.com/public_html/wp-content/plugins/wordpress-seo-premium/vendor_prefixed/j4mie/idiorm/idiorm.php(464): PDOStatement->execute() #1 /home/customer/www/paastoa.com/public_html/wp-content/plugins/wordpress-seo-premium/vendor_prefixed/j4mie/idiorm/idiorm.php(1983): YoastSEO_Vendor\ORM::_execute(‘INSERT INTO `wp…’, Array, ‘default’) #2 /home/customer/www/paastoa.com/public_html/wp-content/plugins/wordpress-seo-premium/src/orm/yoast-model.php(662): YoastSEO_Vendor\ORM->save() #3 /home/customer/www/paastoa.com/public_html/wp-content/plugins/wordpress-seo-premium/src/models/indexable.php(160): Yoast\WP\SEO\ORM\Yoast_Model->save() #4 /home/customer/www/paastoa.com/public_html/wp-content/plugins/wordpress-se in /home/customer/www/paastoa.com/public_html/wp-content/plugins/wordpress-seo-premium/vendor_prefixed/j4mie/idiorm/idiorm.php on line 464

    I just tried it with the Yoast Test Helper plugin and the “Reset indexables & migrations” button, it now loads but stoppes at Object 125 and shows the same message: Something went wrong while optimizing the SEO data of your site. Please try again later.

    The website itself seems to work fine (https://www.paastoa.com), except the pages with Learndash Courses: https://www.paastoa.com/kurs/intervallfasten/

    • This reply was modified 10 months, 2 weeks ago by amirzwp.

    It happens the same to me.

    Plugin Support djennez

    (@djennez)

    Hi @frafor and thanks for the report and screens! Can you check your error logs to see if there are any errors at the moment you try to run the indexable command?

    The undefined title bug is indeed known and is being fixed 🙂

    I am having the exact same issue, it says “Object 20125 of 35 processed” and counting. My WordPress debug logs show nothing.

    It worked now on my end, by doing a backup of the website version from yesterday.

    Thread Starter frafor

    (@frafor)

    @djennez I’ve checked both php & web server logs and I cannot find anything related

    It still fails after updating on a news website. In other two that I have recent without problems but in a large one, nothing fails.

    I’m having a similar problem. One of my sites went fine. Then the other at about 80% completion said something went wrong. Then it would let me do 24 objects at a time until the final object. It’s stuck on the very last one and just keeps popping up the speed up your site box every time I refresh the page.

    Sorry I posted on the wrong topic. My indexation process did not start at all which is a different issue. I cannot delete this post but I will post on https://wordpress.org/support/topic/something-went-wrong-while-optimising-the-seo-data-of-your-site-please-try-agai/ as it makes more sense there 🙂

    It does not work for me either with the hotfixes.

    In the JS console I have the following 2 errors:

    
    wp-seo-indexation-1401.js?ver=14.0.1:1 GET https://xxxx/wp-json/yoast/v1/indexation/posts 404
    
    wp-seo-indexation-1401.js?ver=14.0.1:1 TypeError: Cannot read property 'length' of undefined
        at wp-seo-indexation-1401.js?ver=14.0.1:1
        at tryCatch (wp-polyfill.min.js:1)
        at Generator.invoke [as _invoke] (wp-polyfill.min.js:1)
        at Generator.t.<computed> [as next] (wp-polyfill.min.js:1)
        at r (wp-seo-indexation-1401.js?ver=14.0.1:1)
        at wp-seo-indexation-1401.js?ver=14.0.1:1
    

    When I manually do a GET on https://xxxx/wp-json/yoast/v1/indexation/posts I have 404 with the JSON content:

    
    {"code":"rest_no_route","message":"No route was found matching the URL and request method","data":{"status":404}}
    
    • This reply was modified 10 months, 2 weeks ago by Fabian.
    torstensbuechereckede

    (@torstensbuechereckede)

    I’m also running into that error. Mysql Community 8.20, WordPress latest, PHP 7.4. Ubuntu 20.04 LTS, Nginx 1.18

    75675 of 3239 processed and if I stop it “something went wrong”

    I try to optimize it but it closes as soon as I press.

    Yoast 14 indexing runs beyond the number of objects to treat here, like 7901 / 2631.
    I wonder when (or if) it will finish…

    • This reply was modified 10 months, 1 week ago by studioavanti.
    • This reply was modified 10 months, 1 week ago by studioavanti.
    Plugin Support devnihil

    (@devnihil)

    @frafor @amirzwp @liberalcastilla @jordh @rsmith4321 @carmano @studioavanti @torstensbuechereckede If you update to the most current version of Yoast SEO version 14.0.4, does this resolve the issue?

    torstensbuechereckede

    (@torstensbuechereckede)

    Not for me. I also tried the cli command but today the popup notice for indexing showed up again.

Viewing 15 replies - 1 through 15 (of 30 total)
  • You must be logged in to reply to this topic.