Support » Plugin: Yoast SEO » Yoast 14.0.4 keeps indexing (3225 of 11)

  • Hi,

    Please have a look at the video (shared in url). It says Yoast is indexing 3225 objects of 11. If I stop and restart, it starts from 0 but quickly goes beyond the 11 again.

    This is on a site with 8 just 8 pages, but translated with wpml into 7 languages. But I have more sites with wpml that didn’t run into this issue.

    Any idea what could be wrong here?

    Thanks
    JP

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • About 12 hours later, the dashboard still shows the message to speed up the site. When I start it, it says there are 10 objects to process, and when I start it, it goes again well above the 10 until I stop it.

    I did a database maintenance (with InfiniteWP) on these points:
    – Post revisions deleted – 22
    – Auto drafts deleted – 1
    – Spam comments deleted – 0
    – Unapproved comments deleted – 0
    – Trashed posts deleted – 0
    – Trashed comments deleted – 0
    – Unused comments metadata deleted – 0
    – Unused posts metadata deleted – 1
    – Pingbacks deleted – 0
    – Trackbacks deleted – 0
    – Optimize database Tables

    Then with phpmyadmin
    – I repaired the database tables
    – I optimized the database tables

    Then tried to index again and problem remains.

    Does the indexing process get into a loop somewhere?

    Plugin Support Maybellyne

    (@maybellyne)

    Hello,

    If you haven’t already, please try the following:

    • Install & activate the Yoast Test Helper plugin
    • Go to Tools -> Yoast Test
    • Hit the “Reset indexables & migrations” button
    • Delete your current Yoast SEO installation.
    • Update to Yoast SEO 14.0.4
    • Click the “Click here to speed up your site now” button.
    • Does this resolve the issue? We look forward to hearing from you.

    Thanks @maybellyne

    Unfortunately that didn’t fix it.
    It has 365 objects to index, but goes past that amount again.

    Object 702 of 365 processed.

    JP

    Plugin Support djennez

    (@djennez)

    @jpnl it’s a known compatibility issue with WPML, we’re working on a fix for 14.1. See https://github.com/Yoast/wordpress-seo/issues/15050#issuecomment-623502563 for more details.

    Thanks @djennez

    I am not to sure that the issue is about language variants of the term ID’s 1, 13, 14 of Uncategorized.

    I checked the site. It doesn’t use categories so I made a new default category, delete the old one including it’s translations. Did a database maintenance to delete all trash items. Then ran the indexer again and it still happens.

    Any idea how to get around this until the fix is released? I am afraid the indexer is continuously running in the background eating server resources.

    Thanks
    JP

    Plugin Support djennez

    (@djennez)

    @jpnl if you don’t start the indexer manually, it will not run. The tables will only get filled lazily (so once an object is visited / saved, it will be stored to our table). You can ignore the indexation message until 14.1 and try again then.

    @djennez ok, but even when it will get filled lazily, it will be an endless process. Right?

    Plugin Support djennez

    (@djennez)

    @jpnl hmm, not sure. Can you check if you can find duplicate entries in the wp_yoast_indexable table of your site? I am wondering if those are terms or not. The object_id should be duplicate, possible the permalink and permalink_hash as well. With the WPML compatibility problem, we saw duplicates of the main term, so if translations of that term were indexed they would be stored as the main term. Maybe visiting those translated term pages will add them to the database correctly.

    There are a lot of duplicates. I ran this query

    SELECT *, count(*) as cnt FROM hws_yoast_indexable
    group by object_id, permalink, permalink_hash
    HAVING cnt > 1

    And get the 4 results below. look at the number of records that are grouped in each result. I removed the hash and changed the domain name here for security reasons.

    This is all stuff that seem to originate from Divi, not WPML. The thing is, I have 44 sites with Divi and 11 of them with WPML (like this one) and this issue is only on this site.

    permalink 		https://www.mydomain.nl/layout_type/section/
    object_id 		4
    object_type 		term
    object_sub_type 	layout_type
    breadcrumb_title 	section
    cnt 			232
    
    permalink 		https://www.mydomain.nl/scope/global/
    object_id 		7
    object_type 		term
    object_sub_type 	scope
    breadcrumb_title 	global
    cnt 			129
    
    permalink 		https://www.mydomain.nl/layout_type/module/
    object_id 		8
    object_type 		term
    object_sub_type 	layout_type
    breadcrumb_title 	module
    cnt 			227
    
    permalink 		https://www.mydomain.nl/layout_category/sectie/
    object_id 		12
    object_type 		term
    object_sub_type 	layout_category
    breadcrumb_title 	Sectie
    cnt 			232

    Hi again.

    Version 14.1 is supposed to fix this issue and it doesn’t show that ‘speed up your site’ message anymore. However, there are still all does duplicate records in the database.

    I don’t see a reindex option in the Yoast settings/tools. Does 14.1 clean them up by itself? If not, how do I do that?

    Thanks
    JP

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hey @jpnl,

    Thank you for both of your replies.

    Can you please try the following.

    1. Install the Yoast Test Helper plugin found here: https://wordpress.org/plugins/yoast-test-helper/
    2. Go to Tools > Yoast Test
    3. Click the Reset Indexables tables & migrations button
    4. Go to SEO > Tool and click the Start processing and speed up your site now button.

    Can you let us know if that helps?

    Thanks, but the question really was if 14.1 cleans up the duplicate entries by itself? Otherwise I have to follow your steps on 11 websites…

    But, I queried the database on one of the sites before and after the updated and it does clean itself.

    You still might want to have a look at it. There is one new record that gets duplicated.

    id		1183
    object_type	system-page
    object_sub_type	404
    title		Pagina niet gevonden %%sep%% %%sitename%%
    cnt		3
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thanks for following up with us. Yes, Yoast SEO v14.1 cleans duplicate entries by itself when running the indexables analysis.

    However, if you see there more duplicate entries left in the database, please do feel free to submit a report for them directly at the development repository so our development team can look into this further.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Yoast 14.0.4 keeps indexing (3225 of 11)’ is closed to new replies.