Support » Plugin: YITH Essential Kit for WooCommerce #1 » YITH Essential Kit upgrade just broke my site

  • Resolved glazergallery

    (@glazergallery)


    Updated Yith Essential plugin to 1.5.1. Boy was I sorry. Got a fatal error that took down my entire site:

    Parse error: syntax error, unexpected ‘[‘ in /data/55/4/41/66/4204229/user/4714197/htdocs/wpmain/wp-content/plugins/yith-essential-kit-for-woocommerce-1/plugin-fw/lib/yit-debug.php on line 237

    Fortunately I had a folder on my hard drive with 1.4.8. I uploaded it and my site works now. But no way will I trust another update without assurances that this is fixed.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hi there,
    I’ve just tested the YITH Essential Kit on a WordPress vanilla install and found no issues.
    Can you share with me your current setup?
    WordPress version
    WooCommerce versione
    Theme in use
    plugins in use

    Thanks!
    Francesco G.
    YITH Developer

    WordPress version: 4.9.2
    WooCommerce version: 3.2.6
    Theme in use: Vantage (SiteOrigin)

    Plugins in use:
    MetaSlider 3.6.7 (Team Updraft)
    Page Builder 2.6.2 by SiteOrigin
    Products Admin Notes Simple 1.1 by Jamie Hall
    SiteOrigin CSS 1.1.5 by SiteOrigin
    SiteOrigin Widgets Bundle 1.11.3
    Ultimate Social Media 1.8.2 by Ultimately Social
    WooSidebars 1.4.3 by WooThemes
    WP All Import – WooCommerce Add-On Pro 2.3.8 by Soflyy
    WP All Import Pro 4.5.0
    WP Super Cache 1.5.9 by Automattic
    YITH Essential Kit for WooCommerce #1 1.4.8 (I rolled back to this and everything works fine)
    YITH WooCommerce Catalog Mode 1.5.7

    Plugin Author YITHEMES

    (@yithemes)

    Hi there,
    if you have the opportunity to do this… can you please try the last version of YITH Essential Kit without the Catalog Mode plugin?

    Francesco G.
    YITH Developer

    I’ll do that if you can tell me how to do that without having the “Add to Cart” buttons come back. We don’t have a Shopping Cart on our site and we don’t want one. The problem with deactivating the Catalog Mode plugin is that the buttons come back and I don’t want to confuse our customers.

    By the way, today I see that you’ve updated the YITH Catalog Mode plugin so I decided to try out 1.5.9 to see what happened. It broke the site — parse error. These errors are serious as they disable the entire web site. I had to restore 1.5.7. So I’m not even going to try installing any more updates of yours until I know you’ve tested it thoroughly.

    Plugin Author YITHEMES

    (@yithemes)

    Hi again,
    all our plugins are tested together and no issue were raised during the latest tests…Anyway I’m doing a test with latest version of YITH Essential Kit and Catalog Mode Free.
    Can you tell me which version of WooCommerce are you using now? Since 3.3 is out

    Let me know,
    Francesco G.

    YITH Developer

    Plugin Author YITHEMES

    (@yithemes)

    New version of Essential Kit with support to WC 3.3 is arriving in the coming days

    Francesco G.
    YITH Developer

    • This reply was modified 1 year, 11 months ago by YITHEMES.

    As I told you 5 days ago, I’m using WooCommerce 3.2.6 — all the plugins are in the list you requested, above. My plugin list is showing all plugins as up to date, so WooCommerce 3.3 may not have been released to the general public yet. I can tell you that the YITH Essential Kit 1.4.8 and the YITH Catalog Mode 1.5.5 work fine, while installing either one of the newer ones immediately return a Parse Error that locks me out of my site so I can’t even get into the Admin panel, and anyone typing http://www.georgeglazer.com gets the same error message instead of seeing our web site. Having tried this several times I am 100% positive this is not a fluke and I don’t see any reason to try that again with my current configuration. If you look at the first email in the thread, you’ll see what the error says.

    I wanted to let you all know that I think I figured out what was probably creating the problem with the plugin updates. My WordPress site was running PHP 5.3. I had a parse error that paralyzed my site come up with a different plugin last week. I looking at the discussion on that plugin’s forum on WordPress.org, where its developer said it was no longer compatible with versions below PHP 5.4. My web hosting company had options to update to PHP 5.6 or 7.0 available, so I updated to 5.6, and that solved the problem with his plugin. So I decided to try updating YITH again, and now it works.

    I don’t see anything in your plugin documentation on WordPress.org that specifies minimum PHP version but if you agree that this is relevant, I suggest that you add it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘YITH Essential Kit upgrade just broke my site’ is closed to new replies.