Support » Plugin: Easy Appointments » Yikes! Not working after update to WP 4.7.4

  • I just updated Easy Appointments to 1.10.0 and then WordPress to 4.7.4 (from 4.7.3). But now the calendar won’t run properly. The calendar grid doesn’t appear on the page, although the dropdown and fill-in fields do. When I select from the dropdown, the grid still doesn’t appear.

    After I updated WP, I went to the EA section, but got a weird message about having to update the database. So I clicked to update the db and got another weird error message about 3 tables not existing and a category not existing…but it said the db had updated successfully. But since then the EA calendar grid won’t display. The back end of EA seems to be intact.

    I grabbed a screenshot of the error messages but would rather not post them since they contain detailed paths that shouldn’t be made public. I can send it to you privately if it will help.

    Please help! Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Nikola Loncar

    (@loncar)

    Hy,

    can you please open an private ticket in https://easy-appointments.net/support-forum/ . If the backend is fine I am not sure why the form is not showing. šŸ™

    Best regards,
    Nikola

    Were the two of you able to find resolution to this issue? I’m missing the calendar with the [ea_standard] shortcode. This is a fresh install with the latest version of WP. Like you mentioned, I’m able to see the dropdowns and form elements, but no calendar.

    No errors show up in the error_log, and no javascript errors appear.

    Thread Starter Evolvingdoor

    (@evolvingdoor)

    Hi Daniel,

    Well, yes and no. We discovered that the site’s theme was causing a problem. The calendar grid display was being suppressed (display:none) and other general styling (.post and .date) was using theme defaults which interfered with the display of the calendar.

    I’m not sure how it got that way, as the theme hasn’t been updated since January 2017. I have no idea why suddenly it became a problem, since it was fine until the WP update to 4.7.4 and the EA update around the same time. I don’t see how the theme could be the source of the problem, as such, since it hadn’t been updated in months. The only thing I can think of is that EA might have specified CSS settings for the grid which were removed, and would therefore default back to the theme’s settings, but Nikola hasn’t confirmed if this is or is not the case.

    The best way I found to override the theme’s CSS was to simply edit the theme’s CSS directly and comment out those style lines (.post and .date). Normally I wouldn’t recommend this, since any theme updates could overwrite those edits; however I discovered in the process that this particular theme is not being supported anymore, so there will be no future updates and no chance that the theme’s CSS will be overwritten.

    So: I have done a workaround by directly editing the theme’s CSS and commenting out .post, .date, and also .postdata (which I had previously set to display:none to suppress display of the post’s date information). But doing this might not be a good solution for you.

    I would like to see Nikola address this issue further, since obviously I’m not the only one experiencing the problem. I am also concerned that migrating my client’s site to a new theme (which is necessary, now that I know the current theme is no longer supported) could bring back the problem again. I would be very interested to hear how your problem gets resolved, Daniel.

    Sorry for the long, complicated explanation, but I hope it will help you look into your problem if you know the details of mine. šŸ™‚

    Wendy

    Wendy,
    I really appreciate the reply. Your response helped me identify where my issue was, even though our particular issues ended up being different.

    My issue was also a theme issue, but it had to do with how I was moving scripts from my header to footer.

    I had these 2 lines in my theme:

    remove_action('wp_head', 'wp_enqueue_scripts', 1);
    add_action('wp_footer', 'wp_enqueue_scripts', 5);

    When I removed them, the calendar renders for me again. I think it has to do with the underscore templates rendered inline from the shortcode. Ideally for me, I think this stuff would be rendered with wp_footer, rather than just output inline. I leave that up to the plugin author, though.

    Thread Starter Evolvingdoor

    (@evolvingdoor)

    I’m glad you found a workaround that fixed it! I would still like to see this problem fixed so that workarounds were not required. Nikola, could you put this on your fix-it list? šŸ™‚

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Yikes! Not working after update to WP 4.7.4’ is closed to new replies.