WordPress.org

Support

Support » Installation » Yet another user with the install.php file problem

Yet another user with the install.php file problem

  • I am trying to install the latest WordPress for the very first time, and upon closely following the Famous 5-Minute Installation, and launching the wp-admin/install.php file, I recieve the following error message:
    ********************
    We’re having a little trouble selecting the proper database for WordPress.
    * Are you sure it exists?
    * Your database name is currently specified as b2l1233_wordpress. Is this correct?
    * On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?
    WordPress Support Forums
    ********************
    Like you see on the bottom there is a link to the WordPress Support Forums – so I am here 🙂
    Here is my wp-config.php:
    ********************
    <?php
    /** WordPress’s config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘b2l1233_wordpress’); // The name of the database
    define(‘DB_USER’, ‘b2l1233_dalibor’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘password’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘english’, ”);
    ********************
    Any ideas how to fix this WP gurus? 😉
    +dd

Viewing 11 replies - 1 through 11 (of 11 total)
  • …Also, yes I have created a “wordpress” MySQL database with the user “dalibor” also added via the CPanel.
    +dd

    define(‘DB_NAME’, ‘b2l1233_wordpress’);
    Have you tried just:
    define(‘DB_NAME’, ‘wordpress’);
    That error would seem to mean that it is connecting, but it can’t find the actual database, so maybe it’s the name ?
    If in my cpanel, I click on phpmyadmin or add/remove databases, I see the full name, and that’s what is needed.

    Shouldn’t the user you added via Cpanel be “b2l1233_dalibor”?

    Have you given priveleges to that user to use that database? In CPANEL, there’s a spot to ‘add user’ to database.
    You’ll know if that’s the problem — on the MySQL page, you should see something like this:
    b2l1233_wordpress’
    Users in b2l1233_wordpress’
    b2l1233_dalibor (Privileges: ALL PRIVILEGES)

    Reply to post #3 — I have tried changing from
    define(‘DB_NAME’, ‘b2l1233_wordpress’);
    to
    define(‘DB_NAME’, ‘wordpress’);
    and still, the same message appears when attempting to run the installation file.
    Reply to post #4 — when creating any username, for example “dalibor” then the name needs changes to “b2l1233_dalibor”, since my accound name on with the host is b2l1233.
    Reply to post #5 — I have added the user “dalibor” in the CPanel under the MySQL database “wordpress”, and I do see:
    b2l1233_wordpress’
    Users in b2l1233_wordpress’
    b2l1233_dalibor
    However I don’t see (Privileges: ALL PRIVILEGES) beside the username.

    Is ‘localhost’ correct ?
    Does the cpanel show any sort of example ‘connection string’ ?

    thetrixx,
    you have to click on the button “Add User to db” on the page that you showed in the image above!
    My host just recently updated their servers with CPanel, and I went through the same madness until I figured out what to do 🙂

    podz,
    that right there is a lowercase L, not a pipe (|).
    moshu,
    i’ll give that a try.. hopefully it all checks out good. 🙂

    moshu — that did the tick 😉
    after checking, double checking, triple checking my php it was that little darn button…..
    thanks for the heads up

    Glad I could help!
    Actually because of that “lettle darn button” I spent a whole night just cursing and re-checking everything 100 times… trying to make running 5 or 6 different applications that nedded the DB. Pretty crazy, eh?

    moshu,
    yeah it is. same here, i spend hours checking, and checking again my php because i’d been playing around with it earier, and thought i’d messed something up badly. you’ve saved me a couple of hours!
    here is the blog if you’re interested – i still need to transfer over 3 months of postings from blogger, but here it is anyways:
    http://digidal.buildtolearn.net/

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Yet another user with the install.php file problem’ is closed to new replies.
Skip to toolbar