Support » Fixing WordPress » Yet Another 3.5 "Add media" button failure.

  • As it says in title.
    To troubleshoot so far I have:

    – disabled all plugins
    – have never used Bullet-Proof Security plugin
    – changed to Twenty Twelve and Twenty Ten themes, and a bunch of other themes (strangely, my installation lists Twenty Eleven as missing a template)
    – added define(‘SCRIPT_DEBUG’, true);
    – added define(‘CONCATENATE_SCRIPTS’, false);
    – I am on Dreamhost and mod_pagespeed has never been selected
    – I updated all themes and plugins for good measure

    None of this has worked. What else is left to do?

    FYI #1: I have two WordPress blogs, both are 3.5 upgrades, both hosted by Dreamhost. The other one has no problems whatsoever. I don’t get it.

    FYI #2 : I have had several quite bad failures using Dreamhost’s automatic upgrade on this blog (one being a 403 error, the other being a bizarre bug that made all the text on the dashboard non-clickable plain text rather than HTML or PHP clickable links, making the whole thing unusable – that was the weirdest thing I’ve ever seen.) I’m inclined to wonder if it’s a Dreamhost problem. Anyone?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Rarrg – If you’d like to tell me which blog works and which doesn’t, I can take a look for you.

    You can reply here or email me at mika.epstein AT

    Watching this one with interest because I have a major site on a VPS that is suffering the same issue … It worked before Christmas, but on returning from holiday I’m getting the non-functioning media button issue trying to add images to existing pages.

    … could it be the Mayans were predicting the end of the blogging world?

    gazouteast, I though you used plesk (which we totally do not have on DreamHost). That said, if you’re on DreamHost, we’ve been rolling out a fix for this, so you don’t have to have CONCATENATE_SCRIPTS set. The issue is Google PageSpeed and how it’s compressing already compressed files (we filed a bug with them, no ETA on a real fix at source). You should be able to remove that line from your wp-config now (or turn pagespeed back up).

    If you find any where it’s still not working, an apache config or config+restart should do the trick

    Hi Ipstenu

    I’m seeing this across multiple hosts on almost 30 sites so far today.

    Hosts …
    UK VPS with Plesk
    UK Shared cloud with Plesk
    UK Budget shared with cPanel
    UK shared at 1&1 (bespoke admin panel)
    USA shared with cPanel
    Malaysian shared with cPanel
    and more

    The issue kicked in after New Year in all cases, and in all cases WP was upgraded to 3.5 before Christmas. Only on those sites still pre-3.5 is it not happening.

    Obviously with so many sites, there is a wide variety of plugins and themes. Also a smaller, but still present, variety of PHP & SQL & Apache versions, as well as Linux versions.
    The only constant is WP 3.5

    I’m mystified, frustrated … and as it’s 5 o’clock on a Friday, I’m going home and will look at it on Monday. Enjoy your weekend everyone.

    I don’t know why this never emailed me… Silly alerts.

    Speaking only for DreamHost, our issue was 90% due to GooglePagespeed. We’ve corrected it on our servers, so users on DreamHost should not have this issue, if indeed PageSpeed was the case.

    However, if it persists, then there’s something else at fault, and I’d start looking around the ‘How are files being cached/compressed’ region and if it’s possible to tell it to not cache wp-admin.

    Hi Ipstenu

    Returning to this topic after a couple of months bug hunting.

    Still getting the Add Media issue on most sites, including ones which have zero plugins (not even Akismet or JetPack) other than Total Privacy, because only the demo data is being input before the build starts.

    Strangely, there seems to be a correlation between how many things have been clicked in admin and whether or not the Add Media button works – – On some sites, if I go straight to add or edit a post, the button works for a few uses then bombs out and stops. If I do a few things such as plugin upgrades of settings/options changes before I go to add/edit a post, then the Add Media button doesn’t work at all.

    In Pages, forget it – it never works at all, no matter what I do.

    These are all standalone sites (not multisite) if that helps.

    Still haven’t been able to figure it out, but am currently wondering about wp_enqueue() since 3.5 and the new media manager.


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Yet Another 3.5 "Add media" button failure.’ is closed to new replies.