Support » Plugin: Mailchimp for WooCommerce » Years-long Error (API Request Error – 503 :: on 1866…)

  • atomicnicholas

    (@atomicnicholas)


    Can’t believe it’s been years and this problem appears to persist with users (as seen when doing a search online) instead of Mailchimp resolving the Akamai issue.

    [UPDATE: changing rating from 1 star to 5 stars for the fine support]

    • This topic was modified 4 months ago by atomicnicholas. Reason: Update based on support received
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ryanhungate

    (@ryanhungate)

    @atomicnicholas We’re fully aware that this may be a hinderance for some, but while this may seem like a years long “error”, it’s actually a welcomed protection built into the Akamai api layer. We do have documentation on how to resolve this issue. Have you tried anything on this list yet?

    What a lot of folks don’t know – is that on “shared hosting”, you’re “sharing” an IP address amongst many different account owners that is being used for PHP CURL… and that IP address might be tied to something which was registered by Akamai as something to block.

    Your specific domain IP might not actually be the one which is being blocked, but the PHP CURL might be using this IP address if not defined in your php constants.

    We have a way to override this setting on your server so PHP CURL will actually make use of the proper ip address of your domain on the machine. This would be step 1. Insert your actual IP address into this setting, and that might actually resolve your problem.

    Also – we have instructions on how to test your environment here which could end up where you get a dedicated IP address, or possibly move to another server which is dedicated to your site alone. There are many hosting options which are available that provide this type of “add on” if you’re not using a bare bones machine.

    We would hope that after hearing this – that you might be able to take this information above and resolve your issues.

    Let us know if we can be of any other help.

    Thread Starter atomicnicholas

    (@atomicnicholas)

    Hi Ryan,

    I have yet to try go through all that trouble to try to make this work, and it’s a drag to have to work through that rigmarole, but I’ll do that, even if only because I do appreciate your taking time out to respond to my review, with details that aren’t a boilerplate response.

    It feels like there should be an easier, even automated, solution and workaround to this, but will take your word and assumption that there is no other way.

    Just for that support, I have changed my rating from a 1-star to 5-stars, with my hopes you will still be as accommodating going forward.

    Cheers.

    Plugin Author ryanhungate

    (@ryanhungate)

    @atomicnicholas thank you so much for the kind words and your review update. That means a lot to us 🙂

    If you find yourself still having trouble with this, we’re happy to help. Don’t feel bad about asking questions like this because it’s very technical and just requires a little bit of back and forth between the plugin team, and your hosting provider, or dev team etc. 😉

    Have a great weekend and thanks again for updating the review!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this review.