Support » Networking WordPress » ye olde 'database tables are unavailable' on fresh install

  • Resolved PeterParkorr



    I’m reading Debugging a WP Network and think i need to check the correct database tables were created when installing MultiSite and that .htaccess is not giving errors. How do I actually access my database and view it? Do I login to my host and use MySQL/PHP, or do I use Filezilla?

    I have read Database Description in the codex but that is all about the database and not how to check/view/edit it.

    Also, if my site is installed to /public_html/ do I need to update wp-config database location from ‘/’ to ‘/public_html/’ ?

    Thanks for any help…

    I just moved my domain to a new host and installed a fresh copy of wordpress successfully so I could add MultiSite.

    I made a new user, added a test post ok, and enabled pretty permalinks to check if mod_rewrite was likely enabled by my host. I allowed MultiSite ok, and then followed the instructions to edit wp-config and .htaccess to install. After refreshing my browser I got a database error message and couldn’t login.

    I tried adding the Options FollowSymLinks code to wp-config, but this gave me a different ‘database unavailable’ error message, so I removed it again. I added ‘WP allow repair’ too but didnt use it yet as I don’t want to lock the database if it is not going to help.


Viewing 6 replies - 1 through 6 (of 6 total)
  • I just re-read the ‘repair database?’ wording, and then clicked repair (only repair and optimize locks the db…)

    It gave me these errors it couldn’t fix;

    wp_1_posts: Table ‘travelf7_multi.wp_1_posts’ doesn’t exist
    wp_1_comments: Table ‘travelf7_multi.wp_1_comments’ doesn’t exist
    wp_1_links: Table ‘travelf7_multi.wp_1_links’ doesn’t exist
    wp_1_options: Table ‘travelf7_multi.wp_1_options’ doesn’t exist
    wp_1_postmeta: Table ‘travelf7_multi.wp_1_postmeta’ doesn’t exist
    wp_1_terms: Table ‘travelf7_multi.wp_1_terms’ doesn’t exist
    wp_1_term_taxonomy: Table ‘travelf7_multi.wp_1_term_taxonomy’ doesn’t exist
    wp_1_term_relationships: Table ‘travelf7_multi.wp_1_term_relationships’ doesn’t exist
    wp_1_commentmeta: Table ‘travelf7_multi.wp_1_commentmeta’ doesn’t exist

    Ah. Next steps?!

    I found this similar problem…

    …that was resolved so will check my SQL ID permissions and see if I missed something.

    [Part solved]
    I am sure my SQL user has both create and execute permissions, but found other people who had the same problem when installing MS;

    I reverted to pre-MS wp-config.php and .htaccess files, can log in again. Then I tried to Create Network again, but WP warned me there was an existing network.

    This link in the thread was perfect for helping me delete the relevant MS tables in the database, so I can try installing MultiSite again.

    Wish me luck.

    *Pah. This link;

    Remove WordPress Multisite data


    I’ve found a variety of error logs in an array of folders, all lines saying this;

    PHP Parse error: syntax error, unexpected $end in /home6/travelf7/public_html/wp-config.php on line 1

    Any ideas? Happy frickin Easter!
    (tongue in cheek. head in hands.)

    Red wine, Success! (Cold War Kids)

    My eighth install did the trick. Eighth!!

    What I did in the end:

    Installs after my 2nd attempt I couldn’t get sub-directories option, it kept telling me my install wasn’t new, despite deleting everything in a five mile radius. (I was using SimpleScripts to install WP to try and use the servers permissions to create my database tables without problems.)

    I restored my hosts server to before I touched it (lucky it was available).

    Created database and user, with a user pw that qualified as over 90/100, just in case that was an issue when it came to creating database tables.

    I manually installed WordPress.

    I allowed MultiSite.

    I created blogs.dir, calling it ‘blogs.dir’ – last time I just used ‘blogs’ but FileZilla told me it was a directory – was this the problem?? (I don’t think so as after attempt 1 I couldnt even get this far).

    The rest was as it should have been, I added the extra code to wp-config and .htaccess as I had been (copy/paste). This time however there was no WordPress code in .htaccess at all, whereas last time I got this far there were other lines.

    Lastly, I did a little dance, and then looked at a couple of the links relating to network admin. Oh dear, what was I thinking installing MS in the first place! In for a few fun days.

    I haven’t posted the comedy of errors details of the 7 failed installs, but if anybody wants a good laugh…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘ye olde 'database tables are unavailable' on fresh install’ is closed to new replies.