Support » Plugin: YD Spread Parameter » YD Spread Param: Deprecation?

  • Hi Yann,

    Posted to your site as well as here. Love having YD Spread Param — thank you for your efforts here!

    I know it’s been years since you’ve updated the plugin — but I think that’s because none were needed. We’re now seeing constant flow of deprecation messages in the debug log — that make it hard to read thru the logs.

    Any chance you can do the minor update I believe is needed, and update the plugin? Or, if you are no longer supporting it, any suggestions for a replacement plugin?

    Thanks!
    Neil

    [06-Nov-2020 16:24:13 UTC] PHP Deprecated: Non-static method yd_spreadparam_links::ob_flush() should not be called statically in /home/wordpress/public_html/wp-includes/class-wp-hook.php on line 287
    [06-Nov-2020 16:24:13 UTC] PHP Deprecated: Non-static method yd_spreadparam_links::ob_flush() should not be called statically in /home/wordpress/public_html/wp-includes/class-wp-hook.php on line 287

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter neilticktin

    (@neilticktin)

    Another deprecation error

    Deprecated: Non-static method yd_spreadparam_links::init() should not be called statically in yd-spread-parameter.php on line 540

    The fix is to replace:

    yd_spreadparam_links::init();

    with:

    (new yd_spreadparam_links)->init();

    Any chance you want to update the plugin so that others can benefit?

    Thread Starter neilticktin

    (@neilticktin)

    bump

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘YD Spread Param: Deprecation?’ is closed to new replies.