Support » Plugin: Yet Another Related Posts Plugin (YARPP) » YARPP Plugin: How to manually remove FULLTEXT indexes on the wp_posts table

  • Resolved nissimziv

    (@nissimziv)


    Four years ago I used YARPP Plugin and decided to uninstall it.
    Since then, I saw YARPP foot print on the database – wp_options plus 2 or more tables YARPP_cache or something. I managed to remove these.
    Now, I found that YARPP created FULLTEXT indexes on the wp_posts table.
    My site contains thousands of post and I suspect this greatly slows down sites as mine – sites with a large amount of posts.

    I have seen this quote on the FAQ area of the plugin:

    I removed the YARPP plugin but I still see YARPP-related database tables. Shouldn’t those be removed, too?
    Beginning with version 4.0.7, YARPP includes clean uninstall functionality. If you no longer wish to use YARPP, first deactivate YARPP using the “Plugins” page in WordPress, then click the “Delete” link found on the same page. This process will automatically remove all YARPP-related files, including temp tables. If you manually try to remove YARPP files instead of going through WordPress, some files or temp tables could remain.

    My question is – Since I no longer use the plugin and wouldn’t want to install it just for removing tables and indexes, how do I manually remove FULLTEXT indexes on the wp_posts table.

    What is the correct MySQL command to drop this indexes.
    Thanks

    http://wordpress.org/plugins/yet-another-related-posts-plugin/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author yarpp

    (@jeffparker)

    To be safe, I’d recommend installing the plugin again (it should just take a few seconds), activating it, then deactivating, and deleting it. This will clear up everything for you.

    Thanks.

    Thanks,
    I just found the solution. Here it is for the record and for anyone that wants to run MySQL command inside the database to clear these indexes:

    ALTER TABLE wp_posts
    DROP INDEX yarpp_title,
    DROP INDEX yarpp_content;

    Plugin Author yarpp

    (@jeffparker)

    Thanks!

    Hi,

    This was my solution:

    1) Uninstall and remove the plugin.

    2) Drop the indexes:

    ALTER TABLE wp_posts
    DROP INDEX yarpp_title,
    DROP INDEX yarpp_content;

    3) Download and reinstall the plugin.

    4) If the options to relate title and body do not show up, drop the indexes again, item 2 above.

    5) On plugin settings, run the ALTER TABLE to MyISAM.

    6) Done.

    If you still have problems, probably you need to run the query manually to create the indexes.

    The problem should be related to some sort of time out when installing the plugin for large database as ours, specially creating the indexes.

    Thank you for the plugin.

    BTW,

    I am still not seeing the YARPP Experiments, event looking to at the screen options tab.

    Any idea?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘YARPP Plugin: How to manually remove FULLTEXT indexes on the wp_posts table’ is closed to new replies.