Support » Plugin: Yet Another Related Posts Plugin (YARPP) » YARPP on Homepage

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author jeffparker

    (@jeffparker)

    I see YARPP working on your site but not displaying on the home page. Were you able to hide it with CSS? That would be my recommendation.

    On my homepage, there are query posts that display the featured image and the text excerpt. When the YARPP plugin is active, after the excerpt there is a text version of the related posts immediately after. Here is a screenshot with the extra text outlined: http://imgur.com/MrGWNuK

    How can this text be removed?

    Plugin Author jeffparker

    (@jeffparker)

    I’ve seen this one other time. Do you have “Excerpts” set for YARPP?

    Are there any special settings in your theme that let you tweak the excerpts? The goal would be to find a “switch” that either makes YARPP disappear on the home page or shows a full YARPP list, which can then be hidden by CSS.

    Sorry, but without purchasing that theme, I can’t really test it too well on my server.

    Are you talking about an excerpt option in the YARPP plugin? I don’t see that.

    In the theme, the display options for posts on the homepage are content, excerpt, or none. It is currently set to excerpt.

    If I select ‘display content’, it displays the featured image, the title of the post, any content up to the more tag, then the related posts thumbnails and titles.

    The problem with this for me is that I almost always have an image at the top of the post that is different from the featured image, so even if you could hide everything after the more tag, I’m left with the two images. (http://imgur.com/rCkuNsP)

    Plugin Author jeffparker

    (@jeffparker)

    Actually, I think using “display content” is the way to go for this particular issue. Then, use CSS to hide the Related Posts section and the other image.

    If you need help with the CSS, enable this and I’ll take a look.

    Thanks.

    I’ve enabled the previously mentioned setting. I don’t know how to fix this with CSS so please help me out.

    Plugin Author jeffparker

    (@jeffparker)

    Great. Now just add the following to your theme’s CSS file:

    .home .yarpp-related {display:none !important;}

    This should remove it from the home page.

    I applied the custom CSS and it did remove all the YARPP content after the more tag, however, I am still left with the double image problem. 95% of my posts have an image at the very top and that is the way I prefer it.

    Choosing ‘excerpt’ brings back the original problem that was shown here: http://imgur.com/MrGWNuK

    Choosing ‘none’ works in theory, but then I am only left with the featured image and title, while I would like the original amount of text.

    Plugin Author jeffparker

    (@jeffparker)

    If you’re talking about double images on the home page, maybe you can bring back that setting and we can find another CSS solution to hide the second image.

    Right now, I don’t see double images. Unfortunately, choosing “excerpt” doesn’t let us hide YARPP.

    By ‘double image’ I mean you see the featured image and then the first image in the post – which are sometimes the same, but often different.

    Normally by selecting ‘excerpt’ or ‘none’ only the featured image is displayed.

    The CSS would somehow have to skip over the first image of the post and only display text up to the more tag, in order to leave the display setting as ‘content’.

    Plugin Author jeffparker

    (@jeffparker)

    And it’s quite possible that the CSS could easily skip that image. Do you mind turning on “display content” so we can see how that image is tagged? Thanks.

    Plugin Author jeffparker

    (@jeffparker)

    Or is it turned on already?

    Plugin Author jeffparker

    (@jeffparker)

    Please try this:

    .home div.entry-content img.size-full {display:none !important;}

    I applied the above CSS. The second image is gone, but now the related posts images are back!

    Display ‘content’ is currently on.

    Plugin Author jeffparker

    (@jeffparker)

    You need to leave the other CSS change as well:

    .home .yarpp-related {display:none !important;}

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘YARPP on Homepage’ is closed to new replies.