Support » Plugin: YARPP - Yet Another Related Posts Plugin » YARPP – Disabled automatically

  • Resolved ajaxStardust

    (@ajaxstardust)


    I had YARPP installed on a site about 10 years ago, and only recently rediscovered it. It’s cool, but it seems to be disabled automatically. I don’t notice any malfunctions when it is enabled. Currently running PHP 7.4 but soon to upgrade PHP 8.1.

    Any Ideas what might be causing this? I haven’t noticed anything reported by #WordFence or otherwise.

    Best regards!

    ~~~~~~~~~~~~~~~

    Site Health Info (abbreviated):

    `
    ### wp-core ###
    
    version: 6.2
    site_language: en_US
    user_language: en_US
    timezone: -05:00
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 1
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-1160.81.1.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.33 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 6000
    time_limit: 1200
    memory_limit: 256M
    max_input_time: 120
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 8.0.1 OpenSSL/1.1.1t
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.38-MariaDB-log
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 268435456
    max_connections: 256

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author YARPP

    (@jeffparker)

    Hi @uninvolved Thank you for your patience. This issue you’ve referenced has been patched in v5.30.5. Please upgrade to the latest version.

    The issue was limited to Windows servers and the user would have to have writing permission. If your server is Linux (most are), you were not affected at all. In any case, it is patched now.

    @ajaxstardust are you still facing your issue of the plugin being disabled automatically?

    Thread Starter ajaxStardust

    (@ajaxstardust)

    Thanks. You’re the man. The Coffee-cup-man!
    😀

    Meanwhile, I went with …. i think it’s called Related Posts Thumbnails. I always liked your plugin of course. It provides more customization options.

    It’s great news to know it can be used again, safely and without warnings!

    Cheers and best regards.

    Plugin Author YARPP

    (@jeffparker)

    @ajaxstardust Would you mind checking if YARPP remains installed without getting disabled automatically? It would help greatly.

    Please also let us know if there are any features you’d like to see added in YARPP.

    Would love to have you back in the Coffee Cup family! ☕️

    Thread Starter ajaxStardust

    (@ajaxstardust)

    Sure @jeffparker !

    Hit me up in a day or two and i’ll have a report for you. my WPorg username at gmail.

    See? You make me smile. I think we communicated MANY years ago, way back when. I had the coolest plugin ’cause no one else had thumbnails!

    One of my servers are down right now for bandwidth use after fixing a plugin. I’m not going to slam the plugin like others have. I should have read more about how my plugin configuration actions would affect the site. I’d like to have had a warning that all URL’s sitewide would be changed. It was probably in the fine print. Perhaps that sort of thing should place a plugin in a warning state. I can’t say your plugin ever resulted in a need to basically start over.
    😉

    Alas, with great power comes great responsibility.

    Thread Starter ajaxStardust

    (@ajaxstardust)

    @jeffparker

    I installed and activated YARPP on this site. There are no thumbnails showing at this time.

    If I recall correctly, Yarpp takes some time to propagate. That is, the thumbs don’t show up immediately.

    It’ll be there for now, and the other plugin deactivated.
    Cheers!

    Thread Starter ajaxStardust

    (@ajaxstardust)

    Sorry for making this such a long thread. I’m in the middle of other things, but wanted to accomodate you on this.

    Here’s a screen shot to show example:

    the other plugin:
    https://imgur.com/xFinXx6

    YARPP:
    https://imgur.com/OZvqPh9

    Maybe that’s a configuration issue?

    Edit:
    @jeffparker the plugin has not been disabled automatically yet. no warnings. Initiated a WordFence scan.

    • This reply was modified 7 months, 1 week ago by ajaxStardust.
    Plugin Author YARPP

    (@jeffparker)

    @ajaxstardust YARPP should start to show immediately. YARPP results for a given post are cached on first request and subsequent requests are served from the YARPP cache — queries may be not as fast while the cache primes, but results should still appear.

    In your YARPP settings, do you have “Automatic Display Options” set to show on this page type?

    Thread Starter ajaxStardust

    (@ajaxstardust)

    In your YARPP settings, do you have “Automatic Display Options” set to show on this page type?
    I believe so. I only disable the media type. It’s not a super complicated site.

    But I’m beginning to recall. I think I need to change something in the configuration. I never could get it to work w/ a certain customization. Let me try a few things.

    This is what I have at time of writing:
    https://imgur.com/SRAB30z

    • This reply was modified 7 months, 1 week ago by ajaxStardust.
    Thread Starter ajaxStardust

    (@ajaxstardust)

    @jeffparker
    i’m sorry to report, there are no thumbnails showing.
    🙁

    Please let me know what you need to see in terms of configuration so we can get to the bottom of it. I’ll be “here” the rest of the day, EST “business hours” at least.

    Thread Starter ajaxStardust

    (@ajaxstardust)

    Hi @jeffparker .

    YARPP works great now! I had forgotten how nice YARPP is (in comparison to similar plugins).

    YARPP highlights: the User ability to customize, as illustrated in the provided screencap.

    YARPP Admin Dashboard

    Thank you for your assistance in getting it configured and functioning so well! You rock!
    🙂

    Thread Starter ajaxStardust

    (@ajaxstardust)

    Hey, Jay!
    Referencing this post, I see that a proper solution (or presentation of the problem) wasn’t stated here. I think it’s worth mentioning that @jeffparker went out of his way to ensure the #YARPP was functioning correctly. He skillfully inspected the database tables and was able to debug the malfunction in one afternoon. I don’t think anyone can complain about that! Albeit, @jeffparker might have been trying to see if there was something wrong with his plugin. There was an issue/ error on my site causing #YARPP to malfunction, not the other way around. 🙂

    If you can share the following values from wp-config it would be helpful:

    /** Database charset to use in creating database tables. */

    define( ‘DB_CHARSET’, ‘utf8’ );


    /** The database collate type. Don’t change this if in doubt. */

    define( ‘DB_COLLATE’, ” );

    Indeed, the code was exactly as you suspected. the line in wp-config.php was formerly:
    define('DB_COLLATE', 'utf8-general-ci');

    I changed it to as you suggested, and everything started working again.
    Cheers!

    I believe I maybe be experiencing a similar issue on a different site. I’ll have to investigate.

    • This reply was modified 6 months, 1 week ago by ajaxStardust. Reason: onsite link
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘YARPP – Disabled automatically’ is closed to new replies.