Support » Plugin: Yet Another Related Posts Plugin (YARPP) » YARPP broken in Gutenberg editor?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi @marcdk, thanks for the report! 😀
    I’ve seen that error with an older version of YARPP and Gutenberg, but not with YARPP 4.5… but it’s possible it’s a configuration issue.
    What version of YARPP are you on and what do you have WP_DEBUG set to? (Actually, if you’re handy with a web inspector, seeing the AJAX response would be stellar, but that’s probably asking a bit much… ☺️)

    Marc

    (@marcdk)

    After some research my guess is that this javascript does not get executed: https://github.com/mnelson4/yet-another-related-posts-plugin/blob/master/js/metabox.js

    Because the wp-admin/admin-ajax.php I see is just the call for the opening box which mirrors the same behaviour in classic editor. I gutenberg the actual call for yarpp_display metabox never happens.

    Ok. So kann some rewrite the js to make it more robust and to make it work with gutenberg?

    I pushed a pull request https://github.com/mnelson4/yet-another-related-posts-plugin/issues/6

    this is more or less a hotfix but fixes this problem for now.

    Ya I tried it and it resolves the issue for me, so merges to my GitHub fork. But to be clear, I do h have access to the WordPress SVN repo so can’t push it to everyone else.

    Hi,

    Thanks. And for your comment on not being in possession of the wordpress account: Just make your github repository compatible with this plugin: https://github.com/afragen/github-updater Basically you just add the github uri to the readme.txt and we can all pull from your github account.

    Plugin Author yarpp

    (@jeffparker)

    @marcdk

    Your changes will be pulled in soon enough once the new team has its processes in place. Each release needs to be thoroughly tested before it can be pushed out to everyone. In this case, did you test your PR/code with both the Classic Editor and Gutenberg?

    A gentle reminder that this is the support forums for the official plugin hosted on the official SVN. We strongly discourage anyone to point to an unsupported Github repo for updates.

    I wasn’t aware of that @marcdk, thanks. And thanks for chiming in @jeffparker.
    I will probably add that to other plugins I work on. But ya, switching to receiving updates from my fork on GitHub would be basically abandoning the official version of YARPP located here. It’s a bit of a long story, but I don’t intend to fragment the YARPP user base. Consider my fork an unstable BETA version.
    By the way, I checked and the changes worked for me with the classic editor, but I haven’t had time to test it as extensively as I would if I knew it were going to be released to 200,000+ websites.

    Hi!

    Is this problem fixed with 5.0? It does not appear in the changelog.

    Plugin Author yarpp

    (@jeffparker)

    @marcdk Not yet. Will take a look at this next.

    Plugin Contributor shareaholic

    (@shareaholic)

    Hi @marcdk Fixed!

    https://wordpress.org/plugins/yet-another-related-posts-plugin/#developers

    Also several under the hood improvements and security enhancements. Let me know what you think!

    5.1.0 (2019-07-10)
    Bugfix: Related Posts metabox did not load within Gutenberg Editor
    Bugfix: Fixed ‘Deactivate YARPP Pro’ button, including moving functionality to proper WP AJAX functions
    Enhancement: Related Post thumbnails should not be ‘pinnable’ to Pinterest
    Enhancement: Review Notice
    Enhancement: Modernized Editor Metabox design
    Enhancement: Added ‘Refresh’ button to Editor Metabox

    Hello there!

    Where is the change log the plugin?

    I don’t see it in the plugin page. Any idea please?

    Thank you very much!

    Plugin Author yarpp

    (@jeffparker)

    @ruffo Change Log is always under the “Development” tab. Here’s the link again:
    https://wordpress.org/plugins/yet-another-related-posts-plugin/#developers

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.