WordPress.org

Forums

Yahoo Hosting - Issues with RSS and wp-ContactForm? (10 posts)

  1. CAJarrow
    Member
    Posted 9 years ago #

    Just put my site on Yahoo hosting and cannot get RSS or wp-ContactForm to work.

    Anyone seen this?

    Have already seen thread on email address being from within domain...still cannot get email from wp-ContactForm to arrive.

    Also, RSS feed seems to be none exisitent.

    Tips, Threads?

    thanks.

    CAJarrow

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    What does 'cannot get to work' mean ?
    Whst actually happens / do you see ?

  3. Ilione
    Member
    Posted 9 years ago #

    Hmm my hosting isn't yahoo but I installed wp-contact-form last night. I emailed myself (to another domain) which gave me the mail sent response yet it still hasn't arrived...

  4. CAJarrow
    Member
    Posted 9 years ago #

    Have determined that the wp-ContactForm issue IS due to email needing to come from within domain on this host. (Yahoo).

    Entering sending address as from within domain DOES cause email to be properly delivered.

    As for RSS... I am not too sure at the moment. I have used two RSS readers and neither can find the feed. Tried validating it and does not resolve.

    However, RSS is not my strong suit and this could be something simple. And pointers to setting up and resolving RSS issues?

    Thanks,

    CAJarrow

  5. CAJarrow
    Member
    Posted 9 years ago #

    From what I can determine I have a couple options to fix the "mail" issue with wp-ContactForm...

    - Either hard code in the "From" email address to be something like "admin@yourdomain.com" and I am not sure how to do this...

    - Or use a secondary plugin such as wpPHPMailer to get around the mail restriction.

    Any advice?

    Thanks,

    CAJarrow

  6. moshu
    Member
    Posted 9 years ago #

    Months ago for a client I had to modify the Contactform plugin to work with Y.
    In the form, around line 144 I had to replace the original with this:
    <form action="http://us.1.p.webhosting.yahoo.com/forms?login=your-username-on-yahoo" method="post" name="form" id="contactform">
    (obviously if you are on a different server, you should change the server, too)

  7. CAJarrow
    Member
    Posted 9 years ago #

    In layman's term's...what exactly is this action doing?

    Thanks moshu,

    Craig

  8. moshu
    Member
    Posted 9 years ago #

    This is the first line of the form that sends the "message" to you.

  9. rainangel
    Member
    Posted 8 years ago #

    In case if you are using Yahoo! Web Hosting and is still looking for a way to use WP-contact form ...

    I've just posted the following to two similar threads (63559 & 71862).

    Maybe this could help...

    I just signed up with Yahoo Web Hosting for my wordpress blog. During the setup of WP-contact form, I also encountered the same problem.

    I did the following and now my form works fine. As I am not familiar with how to write out instruction, if I confuse you further during the following explanation, please forgive me. :-)

    Under your Yahoo Web Hosting account, go to Web Hosting Control Panel > Create & Update > php/perl mail setup.

    At PHP/Perl Mail Setup, set your default "From:" field on the right hand side.

    I believe in the attempt to restrict spamming, Yahoo requires all PHP mails to specify a from: and to: address that is in your own domain.

    Then, go to wordpress dashboard and locate Plugin Editor.

    Open the wp-contact_form.php file (version 1.4.3), scroll down to the following:

    if(wpcf_check_input()) // If the input check returns true (ie. there has been a submission & input is ok)
    {

    ******ADD the following line:******
    $from = "your-from-default-in-phpmailsetup@yourdomain.com";
    $recipient = get_option('wpcf_email');
    (make sure your email address set up under Contact Form Options is an address within the domain as well!)
    $subject = get_option('wpcf_subject');

    Scroll through the section on $success_msg = get_option('wpcf_success_msg');

    At the following $headers, add $from; before $name <$email>\n" so that when the email is generated, we've fulfilled the Yahoo! requirement;

    $headers = "MIME-Version: 1.0\n";
    $headers .= "From: $from; $name <$email>\n";
    $headers .= "Content-Type: text/plain; charset=\"" . get_settings('blog_charset') . "\"\n";

    At the $fullmsg, I've added a line to see the email address of the sender but you can omit it:

    $fullmsg = "$name wrote:\n";
    $fullmsg .= wordwrap($msg, 80, "\n") . "\n\n";
    $fullmsg .= "Website: " . $website . "\n";
    $fullmsg .= "Email: " . $email . "\n";
    $fullmsg .= "IP: " . getip();

    mail($recipient, $subject, $fullmsg, $headers);

    Please let me know if it also works for you ...

  10. rainangel
    Member
    Posted 8 years ago #

    Update to my previous post...

    I just found out that you can actually skip the step at Yahoo Web Hosting on PHP/Perl Mail Setup.

    Simply make the necessary change with the WP-Contact Form and the contact form would work fine.

Topic Closed

This topic has been closed to new replies.

About this Topic