Support » Fixing WordPress » xmlrpc.php and Windows Live Writer Error

  • I use Windows Live Writer to write posts to my blog. However, today I cannot publish any new posts using any desktop client. I keep getting errors such as the one below (Windows Live Writer):

    Error attempting to connect to blog at:

    Found: Moved Temporarily

    I’ve made sure that the xmlrpc option under Writing is check in my WordPress options settings. The xmlrpc.php file permission settings are currently “744”.

    I’ve read on several threads that it could be a PHP 5 issue, but this was working for me all last week. Surely something didn’t change on PHP 5 in a few days time.

Viewing 11 replies - 1 through 11 (of 11 total)
  • When looking at your RSD file (used by blog clients to discover XML-RPC information about your blog) I see this at the bottom:

    <!– Page not cached by WP Super Cache. No closing HTML tag. Check your theme. –>

    If you disable WP Super Cache does Windows Live Writer work again?

    This has just been fixed. Download and copy this file into your plugins/wp-super-cache/ folder. (Or download the development version of WP Super Cache)

    Will this work on mu wordpress as well?

    i tried disabling wp-super cache and im still getting the same error messages. do i need to uninstall this plugin?

    Did you try the updated version of the wp-cache-phase2.php that Donncha pointed to?

    Yeah, I automatically upgraded to the most recent version and it was still giving me the errors. So I went and disabled the WP Super Cache and two Facebook plugins I had activated, and it seems to work now. Even though there’s a script error on the page now.

    If you are referring to the “XML-RPC server accepts POST requests only.” message when viewing the /xmlrpc.php URL in your web browser, that’s normal.

    I’d suspect that it was one or some combination of the plugins that was causing the problem.

    I didn’t use supercache but still face this problem, why?

    Ok this is what worked for me…

    Set the following permissions for xmlrpc.php using a FTP client. If you are using CPanel set permissions using CPanel and that is much better.

    Owner (sometimes user) Read: allow, Write: allow, Execute allow

    Group: Read: allow, Write: no permission, Other (sometimes world) no permission

    Now start reconfiguring WLW. It will go up to some point. However it might ask you again to configure manually, like choosing your blog platform (choose WordPress 2.2+ or a higher number if available) and entering Do it. and you are done.


    I also got this problem in the past few days and found the culprit was a Post to Facebook Plugin which happened to be the last plugin I installed.


    The Plug-in causing me grief is entitled Publish to Face Book by David Goldstein.

    If this is the same one as previously mentioned, it doesn’t look very good if the plug-in has caused this issue over such a time. If it is similar names syndrome, then is the issue being fed back from face Book, as I think that it’s API system may have changed in some way

    Update – although the error message first appeared with Live Writer, it also faults out with Blogjet on my desktop, and wpToGo on my G1 phone.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘xmlrpc.php and Windows Live Writer Error’ is closed to new replies.