xmlrpc.php 403 Forbidden error (3 posts)

  1. mkenney
    Posted 7 years ago #

    I've been using Live Writer on and off for the past 6 months. I originally had problems with it and all other desktop blogging software coughing up a 403 error when trying to connect to my blog. I believe that problem was originally caused by the Bad Behavior plugin. I got that straightened out and everything has been running fine until yesterday when I using my cPanel I updated to 2.3.2 I'm now getting the 403 error again and it's not just with Live Writer. Any software trying to connect using xmlrpc is doing it.
    I have change the xmlrpc.php file name. I have removed the Bad Behavior plug in. I have created a brand new wordpress blog and in every case I'm still getting the same error.
    Can someone please explain to me how I can go about trouble shooting this problem? Could it be an issue with my .htaccess file? Any insights are greatly appreciated.

  2. Kafkaesqui

    Posted 7 years ago #

    Have you contacted your host about this? Perhaps they've taken it upon themselves to globally block access to xmlrpc.php.

    Anyway, some possible fixes may be found here:


  3. mkenney
    Posted 7 years ago #

    Kafkaesqui - thank you very much for the link that you sent. The very last response in that thread held the answer. It was an issue with the .htaccess file. I added the example as shown and it worked like a champ.

    solution is..
    adding this into .htacess file
    <Files xmlrpc.php>
    SecFilterInheritance Off

    Thanks again,

Topic Closed

This topic has been closed to new replies.

About this Topic