Support » Fixing WordPress » xmlrpc not working with v1.52 Strayhorn

  • midtoad

    (@midtoad)


    I’ve upgraded to 1.52 and now I want to try a blogging client. So far I’ve tried MarsEdit, Ecto, and 3 Mac OS X dashboard widgets, and none of them work. I suspect some problem with my xmlrpc.php, which is located at http://midtoad.homelinux.org/wp/xmlrpc.php. I also made a copy as xmlrpc2.php. I can reach these pages with a server, but of course I get a message saying “XML-RPC server accepts POST requests only.”

    I recall some security issue a couple of versions back, and had deleted an earlier version of the file. I wonder if it’s possible that I modified my httpd.conf so that it prevents proper functioning?

    Some of the clients that I’ve tried complain that they’re not getting back proper xml.

    Anyone have a suggestion?

    thanks!
    S

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    Deactivate all of your active plugins and try again (preferably with Ecto).

    drobbins

    (@drobbins)

    More than likely this is mod_security issue; I experienced similar issues not too long ago. Try renaming xml-rpc.php to something else – something not using ‘XML’ or ‘RPC’ in the filename – then make sure you change any settings in things like external clients; when they post they should look for the new file, not xml-rpc.php – See if it works.

    midtoad

    (@midtoad)

    hmm. I only had one plug, a Google highlighter, activated, but I disactived it anyway. I then copied xmlrpc.php to xinput.php, and told Ecto to look for that. When it offers to update its cache of articles, it gives the following error:
    A list of blogs could not be retrieved! Please verify the account you created

    Is there anything else I could try?

    thanks.
    S

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘xmlrpc not working with v1.52 Strayhorn’ is closed to new replies.