Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » XMLRPC not working while plugin is active

  • Hi. It’s been a while since I cannot connect to my site from WordPress.com via Jetpack. The xmlrpc.php file doesn’t show anything, it should display “XML-RPC server accepts POST requests only”.

    When I deactivate the plugin, the xmlrpc.php works fine, it displays the text and I can connect it to Jetpack.

    How can I solve this?

    SITE DETAILS:

        Operating System : Linux (64 Bit)
        Server : Apache
        Memory usage : 43.85 MByte
        MYSQL Version : 10.0.38-MariaDB
        SQL Mode : Not set
        PHP Version : 7.2.19
        PHP Safe Mode : Off
        PHP Allow URL fopen : On
        PHP Memory Limit : 256
        PHP Max Upload Size : 8M
        PHP Max Post Size : 8M
        PCRE Backtracking Limit : 1000000
        PHP Max Script Execute Time : 30s
        PHP Exif support : Yes (V7.2.)
        PHP IPTC support : Yes
        PHP XML support : Yes
    
        GD Version : bundled (2.1.0 compatible)
        FreeType Support : Yes
        FreeType Linkage : with freetype
        GIF Read Support : Yes
        GIF Create Support : Yes
        JPEG Support : Yes
        PNG Support : Yes
        WBMP Support : Yes
        XPM Support : Yes
        XBM Support : Yes
        WebP Support : Yes
        BMP Support : Yes
        JIS-mapped Japanese Font Support : No
    
    • This topic was modified 3 months, 3 weeks ago by  Abel Bottello.
    • This topic was modified 3 months, 3 weeks ago by  Abel Bottello.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @akerfeldt,

    We have heard of this issue back in time but it looks like a very tricky one to investigate so our developers couldn’t get to the problem’s root so far.

    I hope that you wouldn’t mind editing wp-config.php file and adding the following lines of code to it:

    define('NGG_DISABLE_SHUTDOWN_EXCEPTION_HANDLER', TRUE);
    define('NGG_DEBUG', TRUE);

    This will allow an error to be written to the site error log (not to the browser); once somebody can provide that error log our developers can investigate this again.

    Thanks in advance!

    • This reply was modified 3 months, 3 weeks ago by  mihai-imagely.
    • This reply was modified 3 months, 3 weeks ago by  mihai-imagely.

    Hi, thanks for the reply.

    I’ve added those lines and tested the site, and as far as I can see, the site root’s error_log file is empty.

    • This reply was modified 3 months, 3 weeks ago by  Abel Bottello.
    Plugin Support gabyimagely

    (@gabyimagely)

    Hello @akerfeldt

    I noticed that Mihai already added the forum link to an existing bug report.
    Let’s try to enable WordPress debug mode as well.
    Would that be fine?

    Debugging in WordPress

    This goes into the same wp-config.php file

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );

    Note: if you already have this code, please comment it first

    define( 'WP_DEBUG', false );

    Let us know how it goes.
    Many thanks!

    Sorry, I already had it enabled.

    This is the log:

    
    [20-Jun-2019 22:27:27 UTC] PHP Notice:  Undefined variable: useragent in /home/radiouas/public_html/wp-content/plugins/photoswipe-for-nextgen-gallery/ngg-photoswipe.php on line 13
    [20-Jun-2019 22:27:27 UTC] PHP Notice:  Undefined variable: useragent in /home/radiouas/public_html/wp-content/plugins/photoswipe-for-nextgen-gallery/ngg-photoswipe.php on line 13
    [20-Jun-2019 22:27:27 UTC] PHP Notice:  ob_end_flush(): failed to send buffer of zlib output compression (0) in /home/radiouas/public_html/wp-includes/functions.php on line 4339
    • This reply was modified 3 months, 3 weeks ago by  Abel Bottello.
    Plugin Support mihai-imagely

    (@mihaiimagely)

    Thanks, @akerfeldt!

    Although, I am not very sure if that will help our developers – I have informed them about the notices that you are getting.

    We’ll keep you informed in case that we’ll have any news from them.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.