Support » Fixing WordPress » XMLRPC error and possible connected issues

  • Hello…

    Host: Go Daddy

    I am having issues with my site:
    – I cannot connect with my Android WordPress app on either device (Galaxy S3 & Asus Tablet)- I get a can’t connect “try later” error but it has been over a week.
    – When I add media (e.g. a pic) from the WordPress post screen, I get an error (says try later, but it remains the same). After I logout and start a new session, the picture actually appears in the media library, but not until I do so (logout, new session)
    – I also use NextGen Photo Gallery Pro by photocrati – when attempting to upload an image or gallery, I get a “php” error and it suggests that it might be a “server configuration” error.
    – When I run this: – for my site, I get the following:

    “This page contains the following errors:

    error on line 7 at column 1: Extra content at the end of the document
    Below is a rendering of the page up to the first error.”

    There is nothing else on the screen

    Steps taken – I tried changing themes. This didn’t help. I did not go through each/all plugins and deactivate them, but I did with many. I also called Go Daddy and they said that everything looked okay from there end.

    I can’t help but think these are related (all the problems started around the same time – at least, as I noticed them when trying to use the above functions.)I am an “advanced beginner,” maybe “intermediate” with WordPress – that being said, I can’t help but think something in the database is corrupted or the like?

    I did go to MyPHPAdmin and looked at the “columns” file – but, that is above my paygrade! Was trying to understand the “line 7, column 1” in the error above.

    Text posts seem to work fine.

    I am at a loss, can someone please tell me if this could all be related and some sort of relatively simple fix? Any assistance is greatly appreciated! I am not sure what Go Daddy can do, beyond gutting things and starting over? Hope not! Thanks for your attention!


Viewing 1 replies (of 1 total)
  • Yikes – tried and got all this:

    Failed to check your site at because of the following error:
    Code Description Addional Info Workaround
    1000002 The RSD document is not well formed. There are characters before the xml preamble.
    link to a support page, sticky forum post with steps to fix it
    This validator checks the validity of the XML-RPC Endpoint of WordPress Sites.
    Source code available here.

    Hide Log
    Date Message
    2014-01-21 02:52:10 try to guess the endpoint by appending the xmlrpc.php prefix
    2014-01-21 02:52:10 xmlrpc request: Array ( [headers] => Array ( [Content-Type] => text/xml [User-Agent] => WordPress XML-RPC Client [Content-Length] => 158 [Accept] => */* ) [method] => POST [body] => <?xml version=”1.0″?> <methodCall> <methodName>system.listMethods</methodName> <params> <param><value><string></string></value></param> </params></methodCall> [timeout] => 30 )
    2014-01-21 02:52:12 Download response: Array ( [headers] => Array ( [date] => Tue, 21 Jan 2014 03:01:49 GMT [server] => Apache [expires] => Thu, 19 Nov 1981 08:52:00 GMT [cache-control] => no-store, no-cache, must-revalidate, post-check=0, pre-check=0 [pragma] => no-cache [connection] => close [set-cookie] => PHPSESSID=40e9eeafb6a936a0c0b5b014ebcb2fb6; path=/ [vary] => Accept-Encoding [content-encoding] => gzip [content-length] => 1287 [content-type] => text/xml; charset=UTF-8 ) [body] => <script type=”text/javascript”><!– wpa2a.targets=[]; wpa2a.html_done=true;if(wpa2a.script_ready&&!wpa2a.done)wpa2a.init();wpa2a.script_load(); //–></script> <!– Custom Facebook Feed JS –> <script type=”text/javascript”> var siteURL = “”; var rootPath = “%2Fhome%2Fcontent%2F32%2F12026832%2Fhtml%2F”; jQuery( document ).ready(function($) { }); </script> <div id=”fb-root”></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); = id; js.src = “//″; fjs.parentNode.insertBefore(js, fjs); }(document, ‘script’, ‘facebook-jssdk’));</script> <script type=”text/javascript”>var addthis_product = ‘wpp’; </script><script type=”text/javascript” src=”//″></script><!–wp_footer–><?xml version=”1.0″ encoding=”UTF-8″?> <methodResponse> <params> <param> <value> <array><data> <value><string>system.multicall</string></value> <value><string>system.listMethods</string></value> <value><string>system.getCapabilities</string></value> <value><string>ngg.deleteAlbum</string></value> <value><string>ngg.editAlbum</string></value> <value><string>ngg.newAlbum</string></value> <value><string>ngg.getAlbums</string></value> <value><string>ngg.getAlbum</string></value> <value><string>ngg.deleteGallery</string></value> <value><string>ngg.editGallery</string></value> <value><string>ngg.newGallery</string></value> <value><string>ngg.getGalleries</string></value> <value><string>ngg.getGallery</string></value> <value><string>ngg.deleteImage</string></value> <value><string>ngg.editImage</string></value> <value><string>ngg.uploadImage</string></value> <value><string>ngg.getImages</string></value> <value><string>ngg.getImage</string></value> <value><string>ngg.installed</string></value> <value><string>demo.addTwoNumbers</string></value> <value><string>demo.sayHello</string></value> <value><string>pingback.extensions.getPingbacks</string></value> <value><string></string></value> <value><string>mt.publishPost</string></value> <value><string>mt.getTrackbackPings</string></value> <value><string>mt.supportedTextFilters</string></value> <value><string>mt.supportedMethods</string></value> <value><string>mt.setPostCategories</string></value> <value><string>mt.getPostCategories</string></value> <value><string>mt.getRecentPostTitles</string></value> <value><string>mt.getCategoryList</string></value> <value><string>metaWeblog.getUsersBlogs</string></value> <value><string>metaWeblog.deletePost</string></value> <value><string>metaWeblog.newMediaObject</string></value> <value><string>metaWeblog.getCategories</string></value> <value><string>metaWeblog.getRecentPosts</string></value> <value><string>metaWeblog.getPost</string></value> <value><string>metaWeblog.editPost</string></value> <value><string>metaWeblog.newPost</string></value> <value><string>blogger.deletePost</string></value> <value><string>blogger.editPost</string></value> <value><string>blogger.newPost</string></value> <value><string>blogger.getRecentPosts</string></value> <value><string>blogger.getPost</string></value> <value><string>blogger.getUserInfo</string></value> <value><string>blogger.getUsersBlogs</string></value> <value><string>wp.restoreRevision</string></value> <value><string>wp.getRevisions</string></value> <value><string>wp.getPostTypes</string></value> <value><string>wp.getPostType</string></value> <value><string>wp.getPostFormats</string></value> <value><string>wp.getMediaLibrary</string></value> <value><string>wp.getMediaItem</string></value> <value><string>wp.getCommentStatusList</string></value> <value><string>wp.newComment</string></value> <value><string>wp.editComment</string></value> <value><string>wp.deleteComment</string></value> <value><string>wp.getComments</string></value> <value><string>wp.getComment</string></value> <value><string>wp.setOptions</string></value> <value><string>wp.getOptions</string></value> <value><string>wp.getPageTemplates</string></value> <value><string>wp.getPageStatusList</string></value> <value><string>wp.getPostStatusList</string></value> <value><string>wp.getCommentCount</string></value> <value><string>wp.uploadFile</string></value> <value><string>wp.suggestCategories</string></value> <value><string>wp.deleteCategory</string></value> <value><string>wp.newCategory</string></value> <value><string>wp.getTags</string></value> <value><string>wp.getCategories</string></value> <value><string>wp.getAuthors</string></value> <value><string>wp.getPageList</string></value> <value><string>wp.editPage</string></value> <value><string>wp.deletePage</string></value> <value><string>wp.newPage</string></value> <value><string>wp.getPages</string></value> <value><string>wp.getPage</string></value> <value><string>wp.editProfile</string></value> <value><string>wp.getProfile</string></value> <value><string>wp.getUsers</string></value> <value><string>wp.getUser</string></value> <value><string>wp.getTaxonomies</string></value> <value><string>wp.getTaxonomy</string></value> <value><string>wp.getTerms</string></value> <value><string>wp.getTerm</string></value> <value><string>wp.deleteTerm</string></value> <value><string>wp.editTerm</string></value> <value><string>wp.newTerm</string></value> <value><string>wp.getPosts</string></value> <value><string>wp.getPost</string></value> <value><string>wp.deletePost</string></value> <value><string>wp.editPost</string></value> <value><string>wp.newPost</string></value> <value><string>wp.getUsersBlogs</string></value> </data></array> </value> </param> </params> </methodResponse> [response] => Array ( [code] => 200 [message] => OK ) [cookies] => Array ( [0] => WP_Http_Cookie Object ( [name] => PHPSESSID [value] => 40e9eeafb6a936a0c0b5b014ebcb2fb6 [expires] => [path] => / [domain] => ) ) [filename] => )
    2014-01-21 02:52:12 the validator haven’t found the XML-RPC Endpoint by appending the xmlrpc.php prefix.
    2014-01-21 02:52:12 Downloading the HTML of the page…
    2014-01-21 02:52:12 Opening URL
    2014-01-21 02:52:12 HTTP Request: Array ( [Accept] => text/html [User-Agent] => WordPress XML-RPC Client )
    2014-01-21 02:52:17 HTTP Response Header: Array ( [date] => Tue, 21 Jan 2014 03:01:51 GMT [server] => Apache [expires] => Thu, 19 Nov 1981 08:52:00 GMT [cache-control] => no-store, no-cache, must-revalidate, post-check=0, pre-check=0 [pragma] => no-cache [x-pingback] => [set-cookie] => PHPSESSID=2723299a1b29aeb7049832378f340f36; path=/ [vary] => Accept-Encoding [content-encoding] => gzip [connection] => close [content-type] => text/html; charset=UTF-8 )
    2014-01-21 02:52:17 HTTP Response Code: Array ( [code] => 200 [message] => OK )
    2014-01-21 02:52:17 Parsing the HTML document trying to match the RSD Endpoint declatation…
    2014-01-21 02:52:17 RSD document found at:
    2014-01-21 02:52:17 Downloading the RSD document…
    2014-01-21 02:52:17 Opening URL
    2014-01-21 02:52:17 HTTP Request: Array ( [Accept] => text/xml [User-Agent] => WordPress XML-RPC Client )
    2014-01-21 02:52:18 HTTP Response Header: Array ( [date] => Tue, 21 Jan 2014 03:01:55 GMT [server] => Apache [expires] => Thu, 19 Nov 1981 08:52:00 GMT [cache-control] => no-store, no-cache, must-revalidate, post-check=0, pre-check=0 [pragma] => no-cache [set-cookie] => PHPSESSID=6ec4167189e53a331262a30d341538c8; path=/ [vary] => Accept-Encoding [content-encoding] => gzip [content-length] => 805 [connection] => close [content-type] => text/xml; charset=UTF-8 )
    2014-01-21 02:52:18 HTTP Response Code: Array ( [code] => 200 [message] => OK )

Viewing 1 replies (of 1 total)
  • The topic ‘XMLRPC error and possible connected issues’ is closed to new replies.