Support » Plugin: Jetpack by » xml_rpc-32601 ERROR – can't connect to

  • Resolved senyoraangelica


    I always get this error when trying to connect to

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32601
    Try connecting again.

    Error Details: The Jetpack server could not communicate with your site’s XML-RPC URL. If you have the W3 Total Cache plugin installed, deactivate W3 Total Cache, try to Connect to again, reactivate W3 Total Cache, then clear W3 Total Cache’s cache.

    I have tried the following fixes but with no luck.

    1. Deleted the cache and disabled my cache plugin (WP SUPER CACHE). – didn’t work.

    2. Disabled all plugins. – didn’t work.

    3. I saw the error message tip on your troubleshooting page.
    My site’s xmlrpc.php?rsd shows β€œXML-RPC server accepts POST requests only.” So does that mean my site is misconfigured? How did that happen? I don’t know anything about lighttpd. I looked everywhere on my cpanel and file manager about it but I haven’t found an “etc/lighttpd” folder to upload a ‘wp-rewrite.conf’ file (which fixed another user’s xml_rpc-32601 error).My site is on a shared web hosting at Hostgator.

    Please help me! I’ve been googling for solutions the past week and nothing worked. This is already driving me crazy. πŸ™
    – Angelica

Viewing 11 replies - 1 through 11 (of 11 total)
  • Anybody? Please…

    Also, things I did but forgot to mention.

    4. With all my plugins deactivated, I reinstalled jetpack with a freshly downloaded file from the website. – still gives me xml_rpc-32601

    5. With all of the above, I deactivated my genesis framework theme and switched it to twenty twelve. – still didn’t work

    6. Offered a sacrificial lamb to the xml_rpc-32601 god. – also didn’t work, it’s still giving me the error!

    help help help

    Plugin Author Jeremy Herve


    Jetpack Mechanic πŸš€

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:

    Hi! I already sent my site url via your contact form 10 hours ago. I also received a ‘donotreply’ reference email. But in case you didn’t get it, I’ll do it again. Please help me huhuhuhuhuhuhuhuuuuu

    Let there be bump.

    Plugin Author Jeremy Herve


    Jetpack Mechanic πŸš€

    Did we reply to your support email? I didn’t find any email mentioning this thread, but I might have missed it.

    If we haven’t replied yet, you will want to send a new email. Thank you!

    Hi, i received this.

    Hi there,

    Thanks for getting in touch. The message you saw about “XML-RPC server accepts POST requests only” is normal. However it looks like you have a maintenance mode landing page which may be blocking access to your full site.

    Some maintenance mode plugins include a checkbox to allow access to xmlrpc. If this setting is available in your plugin, please check it and then try connecting Jetpack again.

    If you don’t have this setting available, you won’t be able to use all the jetpack features until you launch your site and disable the landing page plugin. However, you can use Jetpack in development mode, as explained here:

    However, like I said, I tried installing jetpack with all of my plugins disabled. I even tried it several times without activating my plugins for a day, just to make sure. πŸ™

    Trying again, currently, everything on my site is disabled and the cache deleted but still, I am getting the xml_rpc-32601 ERROR.

    I’m giving up.

    Plugin Author Jeremy Herve


    Jetpack Mechanic πŸš€

    Since I don’t know your site URL, I may not be able to help. But if you reply to the email we sent you, I’m sure we can figure things out with you πŸ™‚

    Yes I have replied to it several times and several times I have mentioned my site URL in it.

    Also, this is the debugging result, if it helps.

    Jetpack Debugging Center
    Testing your site’s compatibily with Jetpack…
    Your Jetpack setup looks a-okay!

    Even though it says my setup is ok, jetpack is still giving me the xml_rpc-32601 error.

    Hi there,

    It sounds like you’re already ruled out the usual causes for this error to appear. Sometimes there can be a problem with code in your .htaccess file that should have been removed when a plugin was deactivated, but is somehow still there.

    You can rule this out by temporarily renaming the .htaccess file (found at the root of your WordPress directory) to -htaccess. This will temporarily stop your custom permalinks from working, as well as disable any other code that may have been inserted by plugins into your .htaccess file. Then try connecting again. After this test, you can rename the file back to .htaccess.

    I’m also seeing an invalid result for your RSS feed, which I believe may be because there are no posts published on your site. Just to rule that out as a factor, can you publish one post just as a test? It doesn’t need anything more than a title and a few words of text.



    Deborah | Happiness Engineer |

    Oh wow! It worked! I’m now connected to Jetpack! Thank you, Deborah!!!! I’m so happy!!! You’re the best Happiness Engineer in my book!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘xml_rpc-32601 ERROR – can't connect to’ is closed to new replies.