Support » Plugin: Yoast SEO » XML Sitemaps not working

  • Resolved Alebo

    (@alebo)


    Hi there,
    I have a problem with the XML Sitemap.
    The URL sitemaps it’s not working correctly; it’s not showing https neither www and internet name domain.

    here u can see the issues i get, Sitemaps > https://pietradifonte.it/sitemap_index.xml

    I state that I’ve being reading many treads about this topic on this support forum and I already tried all the suggested tricks but yet i don’t resolve those problem.

    I try to disable and re-enable the XML sitemap directly from the Yoast SEO, clean the cache, deactivate cache plugin and more… but it’s not working.

    However, if I try to generate the sitemap with an online tool it’s working fine.

    can you help me understanding what’s going on?

    thanks in advance
    best

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support jerparx

    (@jerparx)

    Hello @alebo

    We are sorry to hear about your sitemap issue. We have few questions:

    1. What exact URL are you seeing when you go to WordPress > Settings > General -> Website URL and Site URL field? Do you see the same URL entered on the two fields?

    2. Have you tried clearing your cache before AND after disabling and re-enabling your XML sitemap in SEO > General > Features > XML sitemaps?

    3. Have you tried performing a conflict check and switching your theme to the default WordPress theme?

    Alebo

    (@alebo)

    Hi @jerparx

    1) Website URL and Site URL field are the same
    2)I tried to clean cache before ad after disabling and re-enabling the XML sitemap
    3) I find and resolve the XML problem with Health Check plugin; it was generated by “Relative Url” Plugin.

    Thanks

    • This reply was modified 4 months ago by  Alebo.

    If anyone can help me here as well I tried turning off yoast’s site map then back on as well as checking the domains. I am getting this for my site map error:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <error>
    wp_die
    <title>
    <![CDATA[ WordPress &rsaquo; Error ]]>
    </title>
    <message>
    <![CDATA[ ERROR: This is not a valid feed template. ]]>
    </message>
    <data>
    <status>404</status>
    </data>
    </error>

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.