Yoast SEO
XML Sitemaps not working (3 posts)

  1. datysdal
    Posted 2 years ago #

    I have deactivated and reactivated plugin but the sitemap is not being generated. Here is the address: http://www.travelinsurancereview.net/sitemap_index.xml

    Thanks in advance for any help


  2. screencaffeen
    Posted 2 years ago #

    I just downloaded 1.4.4 and am having the same problem. I can see the category-sitemap.xml and post_tag-sitemap.xml, but not the post-sitemap.xml or page-sitemap.xml. When I click on the link, I get the message from my 404 template.

    Doesn't seem like it should be a permissions issue, since 2 out of 4 are being found. When I add a new post or page, I see that these xml files are updated on the fly. But I still get the error after the file is regenerated.

    Appreciate any insights.

  3. Hedi
    Posted 2 years ago #

    You get the 404 error when the post-sitemap.xml / page-sitemap.xml is empty.

    Maybe this will help :

    I had Post and Page missing in post-sitemap.xml / page-sitemap.xml. It was the Post/Page having the options "Include in Sitemap" is set to "Auto detect" AND "Meta Robots Index" is set to "Index"

    You may change your post/page options this way :
    "Include in Sitemap" set to "Always include" should work.
    "Meta Robots Index" set to "Default for Post type, currently : Index" should work too.

    If you don't want to change all posts/pages you can modify the plugin file inc/class-sitemaps.php : what works for me is changing the line 326 for the plugin version (line 325 for the plugin version 1.4.4)
    if ( wpseo_get_value( 'meta-robots-noindex', $p->ID ) && wpseo_get_value( 'sitemap-include', $p->ID ) != 'always' )
    if ( wpseo_get_value( 'meta-robots-noindex', $p->ID ) == 1 && wpseo_get_value( 'sitemap-include', $p->ID ) != 'always' )

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic