Support » Plugin: Yoast SEO » XML sitemaps noindex via robots?

  • Resolved feh33

    (@feh33)


    I have just discovered an issue through Ryte which says most of my XML sitemaps folders via Yoast are noindex via robots. I have set them all to on in the Yoast settings (and “yes” under content type tabs in “search appearance”)… Date in snippet preview was to hide. Not sure why they are all noindex? Any help?

    issues with :
    page-sitemap.xml
    post-sitemap.xml
    post_tag-sitemap.xml

    author-sitemap.xml, member-only-access also noindex work but happy to have those off.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support devnihil

    (@devnihil)

    @feh33 Can you please provide us with the URL of the sitemap so we can review this further?

    Thread Starter feh33

    (@feh33)

    fifthelementalhealing.com

    http://fifthelementalhealing.com/sitemap_index.xml

    Ryte says all of the below are no index via robots:
    http://fifthelementalhealing.com/author-sitemap.xml
    http://fifthelementalhealing.com/page-sitemap.xml
    http://fifthelementalhealing.com/post-sitemap.xml
    http://fifthelementalhealing.com/post_tag-sitemap.xml

    (not sure why category is ok.. and not no index)

    I have the latest Yoast. I recently had to revert to a 3 week old site backup due to another issue from a plugin developer doing something strange which effected my media files, so not sure if this could have effected it somehow…But I reverted to before they had access so it shouldn’t effect that.

    I also have author archives set to enabled and yes, but no for “archives for authors without posts”

    Thread Starter feh33

    (@feh33)

    Also, This error warning is coming up in google search console dated from yesterday:

    “Some URLs listed in this Sitemap have a high response time. This may indicate a problem with your server or with the content of the page.”

    That is for /category-sitemap.xml only.

    I havn’t had an issue before so not sure if it is my server etc. or somthing with Yoast.

    • This reply was modified 3 years, 7 months ago by feh33.
    Plugin Support Michael Tina

    (@mikes41720)

    Hello,

    We are unable to find any noindex tags in your XML Sitemap, so we’re not sure why Ryte is giving you this notification message.

    Could you please try to disable and re-enable your XML Sitemaps as well as flush out the cache if you have any cache plugins?

    Please also try to delete your sitemap from Google Search Console and re-submit it by following the steps here — https://kb.yoast.com/kb/submit-sitemap-search-engines/

    Thread Starter feh33

    (@feh33)

    Hi Michael.
    I have followed your instructions.
    I deleted the sitemap from google console, then resubmitted (after first disabling and re-enabling). Once I refresh the page, the same warning comes up for /category-sitemap.xml only.

    “Some URLs listed in this Sitemap have a high response time. This may indicate a problem with your server or with the content of the page.”

    I am actually currently using the free Ryte access as I was testing it out. So I can not re-analyse it in there until next month to see if this issue is actually resolved in regards to it saying they are “no index via robots”..

    I did just test them in robots.txt tester I found in search console suggested on another site and it does say “allowed” for these sitemaps… So it is possible it is just Ryte with the issue? Although not sure what this new warning is from Google Console, and why that only comes up for the exact subfolder which is according to Ryte the only one not to have noindex via robots… ?

    • This reply was modified 3 years, 7 months ago by feh33.
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We looked at your robots.txt and we can confirm that it is technically correct and there are no disallow rules that could block your sitemap from being indexed.

    On the other hand, the error you are seeing in the Google search console property is related to the loading time. Google crawler find your sitemap loading time higher than usual and as such you are seeing the notice.

    In order to improve the sitemap loading time, we recommend you please reach out your web hosting provider as the loading time mostly depends on the web server.

    I have the same issue not exactly but my posts are also disallowed indexing by robots. I just figured this out that the cloudflare is making those disallowed tag from robots preventing my posts to be indexed. If you’re using cloudflare try disabling it.

    Thread Starter feh33

    (@feh33)

    Thanks Kuro. I am not using cloudflare. It appears to be an issue with Ryte and I might contact them about it..

    Plugin Support devnihil

    (@devnihil)

    @feh33 Thanks for confirming the source of the issue. We are going ahead and marking this issue as resolved. If you require any further assistance please create a new issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘XML sitemaps noindex via robots?’ is closed to new replies.