Support » Plugin: Yoast SEO » XML Sitemap not showing header links and no click-able links

  • Resolved WP-ME.com

    (@wp-me)


    Hi,
    My sitemap not showing the header that contains links to Yoast.com website and the links in the sitemap are not click-able.
    Here is my sitemap: https://wp-me.com/sitemap_index.xml

    I’ve tried the following:

    • Disabling the XML Sitemaps functionality and enabling it again.
    • Deactivating Yoast SEO and reactivating it again.
    • Deleting Cache
    • Updating old post in order to generate new sitemap
    • Searching for error in Yoast KB

    But nothing fixed the problem

    Thanks in advance!

Viewing 6 replies - 1 through 6 (of 6 total)
  • I don’t know how you can fix it, because I see cloudflare headers in server’s response. Reason is wrong Content-type.

    $ curl -I https://wp-me.com/page-sitemap.xml
    HTTP/1.1 200 OK
    Date: Sat, 03 Dec 2016 07:27:00 GMT
    Content-Type: text/html; charset="UTF-8"
    
    $ curl -I https://wp-me.com/sitemap_index.xml
    HTTP/1.1 200 OK
    Date: Sat, 03 Dec 2016 07:25:46 GMT
    Content-Type: text/html; charset="UTF-8"
    

    Content-Type for sitemaps (they are xml files) should be text/xml. You need to check all cache layers.

    PS. Some cache plugins (eg. supercache) serve all files as text/html. More info at https://github.com/Yoast/wordpress-seo/issues

    Yes, the problem is with WP Super Cache.
    When I disabled caching, sitemaps return to work normally.
    What should I do to disable caching sitemaps?

    In SuperCache you can do this via SuperCache >> Advanced >> Accepted Filenames & Rejected URIs >> Add here strings (not a filename) that forces a page not to be cached:

    sitemap_index.xml
    .*-sitemap.xml

    By default supercache already have there: wp-.*\.php and index\.php. Add these lines bellow index.php.

    I’ve created simple action (PHP code) which is more general solution. I think that previous settings work, but I didn’t test them.

    More info:
    https://github.com/Yoast/wordpress-seo/issues/5964
    https://github.com/Yoast/wordpress-seo/issues/5110

    That’s the solution, thank you!

    I checked my sitemap and it seems ok ? Has the bug been fixed ? Thanks.

    RESOLVED

    Just wanted to add that Sasa’s answer worked for me.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘XML Sitemap not showing header links and no click-able links’ is closed to new replies.