Support » Plugin: SEOPress, on-site SEO » XML Sitemap > 404 error / multisite on NGINX

  • I’m getting a 404 error with the XML sitemap. It’s a multisite (subfolders) on NGINX.

    The suggested code for the NGINX conf to rewrite the sitemap URL works as expected for single sites–I have some single sites also on the same NGINX VPS. But it’s not working for rewriting for the multisite and just leads to a 404.

    Flushing permalinks and clearing cache has no effect. I’ve also tried toggling the XML sitemap feature on and off and reinstalling the plugin.

    I also have a Pro license. I put in a support ticket in early December but have not received any meaningful response. I’ve also tested with just the free version of SEOPress but am getting the same result.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Kinda sad that after two weeks you’re a paying customer still waiting for help.

    I stumbled on this while deciding between SEOPress and RankMath. The biggest complaint in most of my search results was how SEOpress support is non-existent, even with the Pro version.

    Hope you get help with your 404 issues, but as of right now this unresolved topic apparently only helped. Rankmath.

    • This reply was modified 2 years, 7 months ago by Dave.

    FYI, support for paid version of any plugin is banned on this support forum.

    Of course, the OP has the same issue on free version too. Probably, a review is the right place to discuss this. Again, no review can be done for paid version of any plugin.

    Plugin Author Benjamin Denis

    (@rainbowgeek)

    Sorry for the response time.
    I am always looking for a solution hoping to give you an answer very quickly.
    NGINX is always more complicated to manage than Apache.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘XML Sitemap > 404 error / multisite on NGINX’ is closed to new replies.