Support » Fixing WordPress » XML-RPC ping failed

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi,

    I get a similar thing, installed WordPress 1.5.1.2 for the first time at the weekend and installed the feedwordpress plugin, added a couple of feeds and the feeds are fetched and posted but get an error similar to above xml-rpc ping failed (local) on http://www.coolwebpagetools.com/blog/

    Tried different feeds and checked validity of each one but still get same error.

    Regards

    Rob

    Just to post the actual error i get when using the feedwordpress plugin
    update-feeds: instruct FeedWordPress to look for new syndicated content

    Sending ping to <http://www.coolwebpagetools.com/blog/xmlrpc.php&gt;…

    The XML-RPC ping failed (local): parse error. not well formed

    ? Return to WordPress Dashboard

    The feeds update but i get that error message.

    Regards
    Rob

    Same here – The XML-RPC ping failed (local): transport error – could not open socket – Any ideas?

    Must be something to do with that URI

    Moderator James Huff

    (@macmanx)

    Download WordPress again. If you haven’t upgraded to v1.5.1.3 yet, do so now. If you have, delete your copy of xmlrpc.php and replace it with the copy from the download.

    nicolariva

    (@nicolariva)

    I’ve downloaded WordPress again and updated to v1.5.1.3 (impossible to find the download by the way) but the problem still exists…

    please help me 🙂

    drobbins

    (@drobbins)

    I’ve had the same error and I’ve been trying to find an answer everywhere:

    http://wordpress.org/support/topic/42691

    I’ve even completely replaced the installation with an older version when the plug-in was working just fine, and I still get the same error. I am beginning to suspect, maybe, that this is a problem our host/admins will have to solve – maybe something to do with an Apache handler, maybe not – that is just a wild guess. But I’ve asked on here, searched the Web, and the few solutions I did find didn’t work for me. If anyone figures this out PLEASE let me know.

    drobbins

    (@drobbins)

    OK – I heard back from my web admin (they rock!) – here was his response:

    “the problem may be caused by mod_security . It seems there may be a security hole in xmlrpc.php so the firewall is telling the pinging machine “file not found”. What version of xml-rpc and or WordPress are you running?”

    I have yet to hear back from him (because I just now responded to his question) but hopefully he might have some more insight into this later on … All this is well beyond my knowledge, so at this point all I can do is relay messages and follow instructions, but if anyone has any ideas about this, it would be much apprecaited … (and, for the record, I’m using the latest version of WP, but as I’ve said before, I’ve tried everything from the CVS version to 1.5 alpha – and yes, I have been deleting the files before moving the new ones to the server).

    You might find the answer here: http://projects.radgeek.com/2005/05/08/feedwordpress-096-is-loose/.

    There’s a lot with similar problems.

    Thanks … oddly enough, I found a solution simply in renaming xmlrpc.php (and likewise changing the filename in any code that called the file).

    I have the same problem ie. The XML-RPC ping failed (local): parse error. not well formed.
    The feeds don’t update and I don’t get the error all the time. I’ve tried renaming xmlrpc.php but got an identical error when I try to update feeds. What is it actually complaining about here? Is the problem in the feed it’s trying to amalgamate or is it in the arguments being passed to xmlrpc.php?

    Ok, I think i just fixed it by using the ‘Optional’ rss-functions.php mentioned in the install instructions.

    Some of your problems will be cleared up by grabbing the latest version of the class-IXR.php from the SVN trunk of WP, just grab and replace.

    @iceman42…I`m a newbie. Do you mean replace xml.rpc file with IXR.php…?

    No I’m sorry, there is a class-IXR.php in wordpress/wp-includes, replace the older version (1.6) class-IXR.php file with the newer version (1.7) class-IXR.php. Not sure this will work for everyone but it seemed to do the trick for me.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘XML-RPC ping failed’ is closed to new replies.