Support » Fixing WordPress » XML-RPC method missing when logging in with wordpress android app

  • I tried to login to my wordpress site using the wordpress app but can’t login. Keep saying XML-RPC method are missing on the server. Please help me.

Viewing 11 replies - 1 through 11 (of 11 total)
  • If you use a security plugin, it could be disabling that feature.(check the options in the plugin)
    Or your copy of WordPress might be damaged. (Use the Reinstall button on the Updates page)

    Ok. But my wordpress just got updated automatically to 5.0.2 recently. Can it still be damaged?

    Unlikely to be damaged.
    So do you have something that disables XML-RPC?

    No. I don’t have anything that disables it. I have even downloaded a plugin that manages XML-RPC to see if it’s disabled or not and it turns out not disabled.
    But I don’t know why the error keeps saying
    XML-RPC method are missing on the server

    Or can the problem be from my Bluehost hosting?? Because I’ve moved a wordpress site to another hosting and the app do connect without hustle. So I’m thinking the problem is coming from the hosting

    same here, I’ve to use digital ocean hosting, I change host and domain to another droplet, after all, changes were completed, I can’t log in with wp app

    • This reply was modified 10 months, 2 weeks ago by phonehayko.

    I also faced problem when trying login to WordPress using official app it says ” required xml-rpc methods are missing.”
    Please help regarding this issue.

    Screenshot :

    This is issue for sure. Don’t try with this address. I changed it. But fix the issue please.

    • This reply was modified 5 months, 1 week ago by foxm.

    The plugin allows login successfully but after login, can’t upload, draft, publish post. Or even if post draft, publish successfully sometimes, the website not accessible for bit of time from that ip and after sometime it open. But problem remains same, So it’s major issue in APP.

    I wonder why no developer reply in this thread relevancy to the problem. WordPress sucks !!

    • This reply was modified 5 months, 1 week ago by foxm.

    Finally found the following solution that worked for me on Raspbian/Buster/Apache/2.4.38/PHP/7.3.4

    sudo apt-get install php-xml
    sudo service apache2 restart

    Still not fixed.a my help?

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.