• I think I have most of the bugs stomped out of the XML-RPC API interfaces now. Most of the big ones were squished over the last few days with the help of the ecto developer. And I just committed fixes for the last of the outstanding problems with timestamps that I was aware of.
    If you are tracking CVS, watch for xmlrpc.php revision 1.39. Or test against any nightly dated 2004-03-17 or later.
    If you had problems with your favorite blog client before, please try again, and post your results here.

Viewing 15 replies - 1 through 15 (of 15 total)
  • post_name is still not being set. see my post at

    Patched and committed. Thanks for bringing it to my attention.

    I don’t know if it has been fixed or not, but the last nightly build still didn’t provide a post slug for entries submitted with ecto.

    I downloaded xmlrpc.php version 1.40 on March 21 and installed it in my WordPress 1.0.1 site. I tried blogging from NewzCrawler version 1.6.4 build 1989, the latest release, and the only XML-RPC API available that works is Blogger. The only XML-RPC API choices in NewsCrawler under the Blog Service=Custom setting are Blogger (the original), MetaWeblog, Blogger 2.0, Movable Type, and LiveJournal. Movable Type, as you know, supports multiple categories. I can’t remember whether MetaWeblog does, and I don’t know about Blogger 2.0 or LiveJournal. Perhaps the WordPress developers and other WordPressers need to have a chat with the NewzCrawler developer so WordPress and its XML-RPC API is one of the supported Blog Services. I’ve just made the suggestion myself to info@newzcrawler.com — David Mattison, http://www.davidmattison.ca/wordpress

    Things seem to be working fine with ecto as of this morning’s (3/21) CVS.

    David, you can’t mix and match from 1.0.x and the CVS, because there were database changes between then so xml-rpc.php actually functions differently in addition to the bugfixes.

    Any timeline for including the RPC changes in a release version?

    We probably will not back-port these fixes for the 1.0.x releases. They will be in the next official release version.
    There is no “WordPress API”. We are compatible with the other standard APIs: Blogger, metaWeblog, and MovableType. These are listed in order from simplest to most-capable.
    In my testing, it is now possible to post to WordPress (1.2alpha) using NewzCrawler’s MovableType API support. Though, NC uses some ugly HTML, when formatting posts 😉

    Makes sense to wait for the next release, I was asking when that would be. My only complaint about WP was finding out that it really isn’t compatible with the standard APIs as it claimed to be. I realize that 3rd-party client compatibiltiy is just one part of standards compliance, but for many people it is one of the most important parts.

    Thanks for pointing out that I can’t mix and match the CVS code with the latest release. Bummer. I just tried w.bloggar using the same setup as I have with NewzCrawler. I’ll go back to the original 1.0.1 xmlrpc.php file. — David Mattison, http://www.davidmattison.ca/wordpress

    In my previous testing, w.bloggar (Blogger/b2/metaWeblog API) and Zempt (MovableType API) both worked fine with the 1.0.x releases. Since those were pretty much the only clients I tested with, I wasn’t aware of the API problems until I started hearing reports from people using other clients. So, with 1.0.x, those two clients are your best bet.
    With the fixes in WP 1.2, pretty much every client should work. And if anybody finds one that doesn’t, I’ll do my best to fix it.

    Hello , I have installed the latest Build of WP and now Ecto and NetNewsWire both post just fine, but the posts do not publish, even though they say they are published. I delete them and repost them thru the web interface and the same story posts just fine. ….. Hmmmm.

    I find there is a delay with publishing via ecto. Sometimes you have to wait a minute before the post appears.

    Thanks! Ill give it another try.

    I installed 1.02 this past week and I am unable to post via Zempt or wbloggar. I am getting an error. It tells me only one top level element is available in a document. I’d like to be able to post with either of these clients. Please help me figure out why I am not able to.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘XML-RPC Fixes’ is closed to new replies.