Support » Fixing WordPress » XML Parsing Error: XML or text declaration not at start of entity

  • Resolved Stretty


    Hi there,

    I’ve started getting the following error when clicking on my rss feed:

    XML Parsing Error: XML or text declaration not at start of entity
    Line Number 2, Column 1:<?xml version=”1.0″ encoding=”UTF-8″?>

    The feed link is:

    My url is:

    I googled the problem and it suggested deactivating my plugins one by one until I found the offending one, but none of them seem to be the problem.

    It also suggested deleting blank lines in certain files, but after doing that I got a blank page when I tried to login to wp-admin so had to restore the files.

    Any help would be greatly appreciated.


Viewing 15 replies - 1 through 15 (of 17 total)
  • Sounds like you’ve got an blank line to me. Can only say to read this:

    You didn’t read my whole post did you?

    I tried deleting blank lines and ended up unable to access wp-admin.

    Yes, I did. That’s why I said “Can only say to read this”.

    Fixed it.

    Stretty – how did you fix this problem?

    This is only a problem for me in Firefox. My feed is pulling up in IE. I installed the fix-rss-tool but it didn’t seem to help. Thanks!

    I used the fix-rss-feed plugin and it worked!

    First you install it – then you have to run it.

    I’m having the same problem. I tried this:


    but despite the success for others it did not work for me 🙁

    I then found this thread and this (mentioned above)


    but it looks like the plug-in is MIA. The page comes up blank.

    Does anyone know where I can find the plug-in, or how I can fix this problem. I’m on 3.1.x (I think). I’m on the latest release as of today.

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    Thanks Esmi. I’ve seen two threads on this topic. Plus the comments on the site of this rss-fix plug-in. Frankly, the problem sounds more complex than that.

    In fact, per your suggestion, I just deactivated all my plug-ins and I still get the error. I’m not sure when this started. It was just pointed out to me today. I am sure that when I launched the site a couple years ago the RSSs worked.

    I can’t say for sure but since I’m only running a handful of plug-ins I don’t think I added anything since the launch. The exception might be WP-DBManager. But even with that turned off, the RSS still bombs.

    I’m open to suggestions. I’m also kinda disgusted that I got smacked in the head by a WP upgrade. I’ve been off billable hours since mid-afternoon. This is not pleasant surprise.

    FYI – The default theme bombed as well.

    Is it possible there’s something buried in a WP cache, or something stored in the DB that shouldn’t be? I ask because I’m running the same version of WP, on the same host and I’m not having a problem.

    The one that’s bad is the current version of WP. That goes back a couple years, to 2.7 (I think). The other with no problems is a much newer install. In fact, it might have started with 3.x. The theme is different, as are the plug-ins. However, as noted that doesn’t seem to be the issue.

    It’s a long shot guess but my hunch is this has something to do with a flaw somewhere in the upgrade path.

    First, I would like to thank WordPress for wasting the better part of my day trying to fix this. Lucky for me I look good with a bloody forehead (from smashing my head on the desk). LOL.

    Here’s what it came down to, and I’m not even close to being sure why it worked…

    Somehow I ended up looking in wp-includes/feed.php. I was looking for extra lines at the end after the ?>. Well, as it turned out, there was no ?> to close it all up. I agree. That sounds suspect but I swear it’s true. So naturally, I added the closing ?> and uploaded it.

    The site feed now works!!! But the comments feed is still bombing. Not a major of a concern but the fact that one works and one doesn’t it kinda odd, no?


    Well, as it turned out, there was no ?> to close it all up. I agree.

    I seriously doubt that this was causing your problem. The closing ?> is often deliberately omitted to try and avoid these kinds of issues.

    Thanks Esmi. That’s all well and good but obviously someone is not doing something else so we can avoid these kinds of issues. If you search for this issue I’m not alone. I tried all the known fixes and still drew a blank. Un until what I mentioned above.

    I was simply reporting back what I found and what in the end resolved half my problem. Maybe it was a fluke? Maybe it will help someone else?

    Why the comments RSS still bombs, I’m not certain. But while I have you…do you know which files are involved in the RSSs?

    I’m also wondering if it’s not hosting related? I believe my hosting (DreamHost) runs some sort of PHP caching. Maybe in poking around I got that to refresh somehow? Given all the various hosting options and environments maybe there’s a ghost somewhere in some of those machines?

    I hear ya brother, but there’s problem and I’m just trying to fix it. Ya dig? 🙂

    My guess is that the file was corrupted and that, in re-saving it, you restored it.

    Yes, I was thinking something along those lines as well. Given my poking around it seemed like there were 2 solutions and sometime neither worked for some.

    That said Luke, what does The Force say about the fact that my main RSS works and my Comments RSS still bombs?

    What’s the .php for the comments RSS? I’d like to look into that. I thought I knew that it was but withing babbling more, it looks as if I might be mistaken.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘XML Parsing Error: XML or text declaration not at start of entity’ is closed to new replies.