Support » Fixing WordPress » XML Parsing error with RSS Feeds? Disable Feedburner Feedsmith

  • Resolved sjcallas


    For those of you suffering from the following XML parsing error when trying to access your RSS feed and you use the Feedburner Feedsmith plugin, I may have stumbled upon the solution:

    XML Parsing Error: XML or text declaration not at start of entity
    Line Number 2, Column 1:
    <?xml version="1.0" encoding="UTF-8"?>

    After trying many upon MANY of the solutions posted all over the internet, I had nearly given up. However, I did manage to fix it using a combination of two solutions. I’m not sure if it was a combo of both or just the second step that fixed it but doing step 1 and then step 2 can’t hurt!

    Step 1: Download and install this fix (i used the PHP method):

    Step 2: Disable Feedburner Feedsmith

    Step 3: Clear your cache and try accessing your feed again.

    I don’t know if Feedsmith was causing the problem or it was a combo of both, but this solution has worked for me. My guess is if you are running Feedsmith or any other RSS plugin that works like Feedsmith this will be a solution for you. Every time I re-activate the Feedsmith plugin the Feed breaks again.

    Hope this helps.

  • The topic ‘XML Parsing error with RSS Feeds? Disable Feedburner Feedsmith’ is closed to new replies.