Support » Fixing WordPress » XML Parsing Error with my rss feeds

Viewing 8 replies - 1 through 8 (of 8 total)
  • I just moved my blog from a free WordPress hosted blog to my own host. I am now getting a similar error message when I try to get the feed through the RSS entries link on my blog.

    Invalid xml declaration.
    Line: 2 Character: 3

    <?xml version=”1.0″ encoding=”UTF-8″?>

    I followed the directions on this page, and it worked for me.
    There were blank lines at the very end of two of those files, and all I had to do was delete them.

    The feedvalidator instructions did not work for me. Any other ideas?



    Volunteer Moderator

    johnnewton01, site url?

    Please try this plugin fix-rss-feed, it will fix your rss error automatically, and you can get more information from, and you also can get help from the author website

    Worked like a charm flyaga

    Thanks a ton

    I had the RSS XML Parsing error a while ago and was applying all the fixes
    – adding ob_clean();?> before <?php echo ‘<?xml version=”1.0″
    – check your customised theme’s function.php for blanks/spaces between <? php and ?>

    I was using Firefox for my testing and it didn’t work. Then I tried IE and Safari and the feed worked.

    At 1st I thought it was Firefox error, then I tried clearing the cache on Firefox, reloaded and the feed appeared!

    So in case anyone encounter the same prob.. try Clear Private Data when you are testing. You might have already solved the problem but not getting the latest codes when you refresh browser.

    I’m not a code whiz, it’s just my intuitive guess. hope this helps someone out there 🙂

    I’m getting a parsing error.. and I’m not sure how to solve it. I think it all happened when I switched themes. There hasn’t been an update since I switched.

    This is what I’m getting:

    XML Parsing Error: XML or text declaration not at start of entity
    Line Number 3, Column 1:<?xml version=”1.0″ encoding=”UTF-8″?>

    I’ve tried installing plugins to fix my feed, I tried reinstalling the feed files in my wp-includes.. I tried clearing private data. nothing’s working.

    Any ideas??

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘XML Parsing Error with my rss feeds’ is closed to new replies.