Support » Plugin: Safe SVG » XML Parsing Error: undefined entity

  • Resolved relish1227

    (@relish1227)



    Hello,

    I have an SVG that I have both moved up to the server via SFTP AND also uploaded via the Media Library. The one via SFTP works fine, but the one I uploaded is generated an error: XML Parsing Error: undefined entity

    Being that Safe SVG makes the media library uploading possible, I wondered if there could be something in this uploading process that made this happen. Do you have any ideas why this would be?

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You know, I just tried re-saving my SVG in illustrator and this second version uploaded just fine with no issue. I wonder what could have caused it with version #1. (I also tried re-uploading version #1 to see if it was some fluke in uploading — but that one still doesn’t upload right.)

    Plugin Author Daryll Doyle

    (@enshrined)

    Hi @relish1227,

    I’m sorry to hear that you were having issues. If the second version uploaded correctly but the first didn’t then I can only think that there was an abnormality in the file when exported from illustrator. It’s odd but I suppose it could happen and if the XML isn’t formatted correctly the sanitiser will fail.

    Are you seeing issues with any other files or is it just this one?

    Cheers,
    Daryll

    Plugin Author Daryll Doyle

    (@enshrined)

    Closing due to lack of response.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.