WordPress.org

Support

Support » Plugins and Hacks » [Resolved] XML Parse Error :(

[Resolved] XML Parse Error :(

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author djarzyna
    Participant

    @djarzyna

    Hi Martin,

    I don’t see anything related to the plugin on your site. Dir you disable it?

    Hi

    I get the same error on my site: Cape Town F&T

    Warning: DOMDocument::loadXML() [domdocument.loadxml]: EntityRef: expecting ‘;’ in Entity, line: 15 in /home/ljcremer/public_html/capetown.fashionandtrunk.com/wp-content/plugins/djd-site-post/djd-site-post.php on line 495

    I have another site where it works fine.

    Plugin Author djarzyna
    Participant

    @djarzyna

    Martin, if seen this shortcode on your page: [fep_submission_form] Did you change anything in code because the correct shortcode would be [djd-site-post]?

    Plugin Author djarzyna
    Participant

    @djarzyna

    ljcremer, I just visited your site and saw a stripped down site post form there. I didn’t want to use that form and try to enter a new post on your site just for testing purposes. So since a form is there does this mean it works for you now? If so, can you tell me what the problem actually was and how you fixed it? It’s just because this XML stuff seems to come up every now and then and I just cannot find the cause of this kind of problem. Actually I am thinking about rewriting this plugin without using xml, but this will be time consuming task I really would like to avoid.

    Martin
    Member

    @rastarr

    Thanks, I only allow Contributors to post and they need to use the WP New Post – cuts down my huge plugin list 🙂

    ABCDiamond
    Participant

    @abcdiamond

    I have just got this “XML Parse Error: The function site_post_form did not return wellformed XML:” error today.

    I installed the plugin on two of my sites today. It works well on one site, but the second site shows that error.

    This one works: http://www.abcdove.com/add-your-thoughts-or-opinions/

    This one does not work: http://www.abcdiamond.com/add-your-news

    and it shows this error page:
    http://www.abcdiamond.com/images/DJD-Site-Post-error.jpg

    Emerson4br
    Member

    @emerson4br

    djarzyna, nice plugin, keep great work!

    I solve it, was a permalink problem, i changed wp_login_url( get_permalink() ); to wp_login_url(); in display.php on line 43 i guess and it work like a charm 😉

    in my case, theme-my-login plugin make my life hard, once it has no permalink yet in my project

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] XML Parse Error :(’ is closed to new replies.