Support » Fixing WordPress » XML Import Error- Syntax within File

  • Resolved skipper0802


    Hello All,
    We’re moving a blog over to a hosted linux account at GoDaddy. We have 3.3.2 installed at the root and had all plugins except for “WordPress Importer” deactivated. Jetpack could not connect to giving us this error:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32601
    Try connecting again. Error Details: The Jetpack server could not communicate with your site’s XML-RPC URL. If you have the W3 Total Cache plugin installed, deactivate W3 Total Cache, try to Connect to again, reactivate W3 Total Cache, then clear W3 Total Cache’s cache.

    We tried ~8 attempts at importing the XML file from the new, hosted WordPress dashboard. The result was an http 500 error:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log. Apache Server at Port 80

    Note: no helpful information was discovered from this log.

    We had about 5 calls to GoDaddy support to help fix the issue…no success. They did what they could on their side.

    We also tried importing the XML file directly into the database. We received this error:

    There seems to be an error in your SQL query. The MySQL server error output below, if there is any, may also help you in diagnosing the


    ERROR: Unknown Punctuation String @ 1
    STR: <?
    SQL: <?xml version=”1.0″ encoding=”UTF-8″ ?>
    <!– This is a WordPress eXtended RSS file generated by WordPress as an export of your site. –>…and
    …MySQL said: Documentation
    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near

    ‘<?xml version="1.0" encoding="UTF-8" ?>
    <!<rss v’ at line 1

    Can anyone help with this SQL/XML syntax error? (The whole XML error discription is available if any wants to look at it…quite lengthy though.)

    Barb and I would really appreciate some pointers as to the cause.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Go Daddy


    Go Daddy Support


    I would try a couple things to troubleshoot. First, try pulling the export from the current site again, just in case there was a problem getting it the first time. You might also try exporting it in parts – export just posts without comments or other data, and see if that imports properly. Try each part individually because it’s possible that some bit of a data in one particular area is causing the problem (like bad code/characters in a spam comment).

    If that doesn’t work, are you able to get a full SQL backup of the current database? If you could, you should be able to import that to your new account. Here’s some info for importing/restoring databases: – just remember that restoring a database also means losing everything that’s currently in the database. Also, note that you need to place the .sql file in the /_db_backups/ folder in order for it to be restorable through the Go Daddy backup/restore interface.

    As a side note, I just visited the site (appears that it’s not hosted from your new account yet), and it looks like you have no pagination for your posts – many, many, many posts show up on the home page. This is generally a bad idea and can cause major performance issues (as it did for me when I visited). I recommend implementing pagination for better performance.

    [ Signature moderated. ]

    This issue is resolved.

    The folks over at Laughing Squid (LS) hosting service impressed the heck out of us by recommending fixes that worked.

    Paste under the “define(‘WP_DEBUG’, false);” line in config.php. Once our new setup, import, and DNS re-point was done then these lines can be commented-out, or deleted:


    Note: the “” string is specific to our LS site management admin menu. Yours may vary.

    This fix enabled us timely and trouble-free logins to configure our new theme, import the backup XML file without issue from our free blog (at, and basically adjust the look and feel of our new site without bothering the viewers at our old site. Check us out here.

    In closing, we are very excited to achieve this milestone in moving to a hosted site location. Our next evolution is to configure a shopping cart for our venture. Best of luck to you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘XML Import Error- Syntax within File’ is closed to new replies.