Support » Plugins » XML Google Maps – problem with “my map”

  • Resolved nrstewart

    (@nrstewart)


    Hi, I am just getting started with wordpress and this plugin (http://wordpress.org/extend/plugins/xml-google-maps/) but I am having trouble getting it to display my map.

    I have created a map in google maps with markers etc, but when I come to add it to the wordpress site all I get is a grey box and the googlemaps navigation controls – no map.

    Clearly I am missing something in my understanding of what the code in the post should look like, or how the plugin works, and cannot find the answer in the existing queries.

    My test page is: http://blog.neilstewart.co.uk/test-map-page/

    The first map is mine with the URL link from “my maps” in Google Maps. The code I have to call the map is as follows:

    <a href="http://maps.google.com/maps/ms?ie=UTF8&hl=en&msa=0&msid=115850690340540587108.000450dec9f76ff939dbd&ll=50.548399,-4.904548&spn=0.004472,0.006738&t=h&z=17">map test</a>

    The second map is a copy of first but with the parameters from one of the examples showing that the plugin is working.

    I have the latest version of the plugin and wordpress and the links are both on a single line.

    Please could someone tell me where I am going wrong?

    Thanks

Viewing 15 replies - 1 through 15 (of 20 total)
  • What you described is a typical result of a JavaScript error with Google Maps. Install Firebug (for Firefox) and turn on the JavaScript console. You’ll see js choking on Google’s obfuscated/packed functions (b.Q() is undefined for example).

    Not very helpful, but it can result from an incorrect use of the Google Maps API. Unfortunately only inspecting the JavaScript line by line will turn up the issue. I’ve seen it happen because the wrong item was passed to a function (ie pass a string instead of a Point to a Google function that requires a Point object as a parameter) or simply because two maps conflicted with each other on the same page. (You’ll want to eliminate this as a possibility).

    You may want to check with the plugin author. I took a quick peek at the plugin code and one thing that may cause erratic issues (or may work fine, depending on the weather) is the fact the plugin has an unescaped URL in the JavaScript. In other words, instead of encoding “page?foo=bar&x=y” into “page?foo=bar&amp;x=y” which is supposed to be the recommended method, it uses the plain ampersand. (This is a common error I’ve been guilty of myself). OR… you could try encoding the URL when you input it to the plugin (however you do that… if it’s through a PHP funstion, check the PHP functions htmentities and urlencode, otherwise you may need to translate it by hand).

    Other than that, it’s hard to determine what the issue is because of the obfuscated errors.

    Hi RogerTheriault, Thanks for your help and advice – I will try and contact the plugin creator and see if they can provide a solution. Many thanks.

    Sorry, this but is not the problem. If you link your Google Map to the Google Earth Link (KML file) not to the Page Link (HTML), then it will work.
    Have a look at the following picture:
    howto01.jpg

    This should help you!

    Firstly thanks for a great plugin! Thanks to the instruction I have now go it working and I am pleased to say it really is simple to use once you have the right link. For anyone that finds themselves in a similar position (and can’t read German too well) the link that you need to use is obtained by right clicking the “View in Google Earth” link and selecting “Copy Shortcut” or similar depending on your browser.

    Many thanks.

    I have a couple of requests as I also cannot get the plug in to display in a Post.

    1) Please can you post an example of the KLM link that you receive by using the “Copy Link Location” from the Google Earth link? (If you save the KLM file and look at the link it end with “&output=kml”… whereas if I just use the link from the clipboard, it is without this ending.)

    2) Your “Help” explanation would suggest that once you have pasted the link into the URL location in the plugin form, that the map is then displayed directly in the Post! Is that correct? (It doesn’t work for me!)

    Thank you.
    Peter

    1) Something like: http://maps.google.com/maps/ms?ie=UTF8&hl=de&msa=0&output=nl&msid=102758581694521177745.000448a802294cf93103c

    2) You cannot directly set http://maps.google.com/maps/ms?ie=UTF8&hl=de&msa=0&output=nl&msid=102758581694521177745.000448a802294cf93103c – you have to make this with an a-tag! “My Map

    To really help your I need some real examples (link to your sample page)…

    Hi dschuesae,

    I’m having a similar problem with my blog I have downloaded and installed your plugin but for some reason I cant get it to display in the blog page, can you please help me. My blog post is at: http://www.jamesapps.com/event/pynk-london-photoshoot/17/08/2008/

    When using Google maps I do not get the google earth link to click on the ‘copy link location’ for some reason (like in your example that you posted) here is a screendump of the googlemaps in my firefo browser: http://www.jamesapps.com/wp-content/themes/jamesapps/assets/images/miscellaneous/googlemaps.png.

    How do you get that google earth link that you right click on: http://www.matusz.ch/blog/wp-content/uploads/2008/01/howto01.jpg

    I have the Google Earth Application installed on my MAC. Whenever I do copy the link location it gives me:

    http://maps.google.co.uk/maps?f=q&hl=en&q=Chantrey+House,+4+Eccleston+St,+Westminster,+London+SW1W,+United+Kingdom&sll=51.494507,-0.147233&sspn=0.011168,0.027723&ie=UTF8&cd=1&geocode=0,51.494507,-0.147233&num=10&ll=51.494183,-0.147243&spn=0.022978,0.055447&t=p&z=15&iwloc=addr&lci=lmc:panoramio

    Thank you
    James

    You really have to save this map first as a “My Google Maps”! It is not possible to save a map that is not saved in the Google Maps API.

    Place your own marker on the map and save it.

    Thank you thats great help I have it working now, cheers! http://www.jamesapps.com/event/pynk-london-photoshoot/17/08/2008/

    urbelab

    (@urbelab)

    Hi
    I’ve same problem. My maps don’t display in my post.
    Here a preview .

    I have tried following Author instruction but I don’t know why this wonderfull plugin doesn’t work in my blog.
    Could anything help me?

    dschuesae

    (@dschuesae)

    Previews aren’t visible for any users… I cannot see what is wrong…

    urbelab

    (@urbelab)

    Sorry, you have reason. I thought it was public for all those post. Now you can control here
    You can see something in this page too.
    Thank you for all dschuesae

    urbelab

    (@urbelab)

    Nothing Else?
    It’s possible that my problem it’s so because in source code there isn’t class “xmlgm”?

    dschuesae

    (@dschuesae)

    I tried your file, they work on my server. So, try it with the latest development version from http://downloads.wordpress.org/plugin/xml-google-maps.zip (I already sent you this by mail).

    urbelab

    (@urbelab)

    You’re very kind Patrick.
    I use your last version (1.10.2) but problem still exist.
    A strange thing is that I have tried yours plugin on an other test domain (with the same host provider of fabrizio.biz) and there it works all.
    Have a look here
    You know if there are plugin not compatible with XMLGoogleMaps?

    Thx a lot

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘XML Google Maps – problem with “my map”’ is closed to new replies.