WordPress.org

Support

Support » Plugins and Hacks » [XML Google Maps] – Get blank map screen

[XML Google Maps] – Get blank map screen

  • I have installed XML Google Maps (1.2) and then upgraded to 1.2.2. Every attempt to use a KML file is resulting in a blank map showing. I can see the navigation/altitude control, the Map | Satellite | Hybrid buttons, the Google icon and the Terms of Use link, but the map itself is grey. See towards the bottom of this blog entry.

    I have tried the GPX file from the authors website and that works fine, so I assume that the plugin is configured correctly. I have tried the sample Javascript from the Google Maps API key page and it works, so the key is fine (and checked it’s valid in the plugin config). But I still get the grey screen.

    The XML I’m testing against is fairly simple:

    <?xml version="1.0" encoding="UTF-8"?>
    <kml xmlns="http://earth.google.com/kml/2.0">
    <Placemark>
    <description>New York City</description>
    <name>New York City</name>
    <Point>
    <coordinates>-74.006393,40.714172,0</coordinates>
    </Point>
    </Placemark>
    </kml>

    It’s straight off the Wikipedia article. I’ve tried a few others but get the same output. Could it be a typo in the XML, or have I misconfigured something to do with KML in the plugin. Is there any debugging option I can turn on in the plugin or WP to get more info?

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[XML Google Maps] – Get blank map screen’ is closed to new replies.