Support » Plugin: WP-Spreadplugin » XML Error Using WP-Spreadplugin

  • Resolved kevumc

    (@kevumc)


    I am getting the below error trying to use this plugin.

    Here is the short code I am adding to the page:
    [spreadplugin shop_id=”2070827″ shop_limit=”20″ shop_locale=”” shop_source=”com” shop_category=”136351″ shop_api=”2f731e7a-bfcd-4813-a86d-6523fd471e9f” shop_secret=”564cb194-03dd-41a3-95e0-34e6acd3642b”]

    Here is the link to the page: http://www.blaaze.org/blaazewear/

    Error:
    Warning: SimpleXMLElement::__construct() [simplexmlelement.–construct]: Entity: line 1: parser error : Start tag expected, ‘<‘ not found in /home/blaazeo/public_html/wp-content/plugins/wp-spreadplugin/spreadplugin.php on line 210

    Warning: SimpleXMLElement::__construct() [simplexmlelement.–construct]: Shop 2070827 does not exist! in /home/blaazeo/public_html/wp-content/plugins/wp-spreadplugin/spreadplugin.php on line 210

    Warning: SimpleXMLElement::__construct() [simplexmlelement.–construct]: ^ in /home/blaazeo/public_html/wp-content/plugins/wp-spreadplugin/spreadplugin.php on line 210

    Fatal error: Uncaught exception ‘Exception’ with message ‘String could not be parsed as XML’ in /home/blaazeo/public_html/wp-content/plugins/wp-spreadplugin/spreadplugin.php:210 Stack trace: #0 /home/blaazeo/public_html/wp-content/plugins/wp-spreadplugin/spreadplugin.php(210): SimpleXMLElement->__construct(‘Shop 2070827 do…’) #1 /home/blaazeo/public_html/wp-includes/shortcodes.php(236): WP_Spreadplugin->ScSpreadplugin(Array, ”, ‘spreadplugin’) #2 /home/blaazeo/public_html/wp-includes/shortcodes.php(151): do_shortcode_tag(Array, Array, ”, ‘spreadplugin’) #3 /home/blaazeo/public_html/wp-includes/plugin.php(173): do_shortcode(Array) #4 /home/blaazeo/public_html/wp-includes/post-template.php(166): apply_filters() #5 /home/blaazeo/public_html/wp-content/themes/maxx-wp/page.php(40): the_content() #6 /home/blaazeo/public_html/wp-includes/template-loader.php(47): include(‘/home/blaazeo/p…’) #7 /home/blaazeo/public_html/wp-blog-header.php(16): require_once(‘/home/blaazeo/p…’) #8 /home/blaazeo/public_html/index.php(17): req in /home/blaazeo/public_html/wp-content/plugins/wp-spreadplugin/spreadplugin.php on line 210

    http://wordpress.org/extend/plugins/wp-spreadplugin/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Thimo Grauerholz

    (@pr3ss-play)

    Hi,

    your shop Id doesn’t seem to be correct. What’s your regular shop URL? xxx.spreadshirt.com ?

    blaazewear.spreadshirt.com

    Plugin Author Thimo Grauerholz

    (@pr3ss-play)

    Hi, use this:

    [spreadplugin shop_id=”396134″ shop_limit=”20″ shop_locale=”” shop_source=”com” shop_category=”” shop_api=”2f731e7a-bfcd-4813-a86d-6523fd471e9f” shop_secret=”564cb194-03dd-41a3-95e0-34e6acd3642b”]

    Your shop id was wrong as I supposed. Additionally, you don’t need to add a “shop_category”, if you just want to display all categories 🙂

    Thanks for using and have fun 🙂
    Thimo

    Plugin Author Thimo Grauerholz

    (@pr3ss-play)

    Hi kevumc,

    can I help you with the plugin or is everything working fine?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘XML Error Using WP-Spreadplugin’ is closed to new replies.