WordPress.org

Support

Support » How-To and Troubleshooting » XML-Error, OPML-Import

XML-Error, OPML-Import

  • Since upgrading to WP 2.1 I get this Error when importing my opml-file:

    Importing…
    XML error: no element found at line 1

    Inserted 0 links into category 56. All done! Go manage those links.

    I searched in the Forum, but can’t find any relating post to WP 2.1. Before upgrading to 2.1 I got the latest 2.0 – Version running and had no Problems with importing from file.

    Any hints or resolutions?

Viewing 15 replies - 1 through 15 (of 31 total)
  • I was able to duplicate your problem. Unfortunately, the only thing I can offer is that I reported it as a bug.

    http://trac.wordpress.org/ticket/3712

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Could we get an example of this OPML document that causes the problem?

    Good idea! Attached to ticket at:
    http://trac.wordpress.org/ticket/3712

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Huh. I took a look at WordPress 2.07’s link-parse-opml.php and 2.1’s version of same. This is the file that parses the OPML input file.

    Other than irrelevant spacing, they are identical. What parses in one should parse in the other, given the same PHP versions on both blogs and such…

    Trying to import your file myself, I also get:
    “XML error: no element found at line 1”. This suggests a problem with the upload process, since the parsing is identical.

    Attached a different file to that ticket Otto42. Thanks for looking at this.

    @kimhbel – if you have a file of opml links, please consider attaching that to the ticket also. Thanks.

    I uploaded two opml-files to the ticket obove. HTH.

    I see that this ticket has not been resolved. Is there any news on this problem. I’m having the exact same problem. It worked fine in the previous version, but I get the same error mentioned above.

    i’ve been attempting this with an exported opml file from bloglines.com. I also tried it with an opml file from google reader, but had the same results.

    This driving me nuts.

    The problem is still unsolved as I could say from my point of view.

    Hope lies in the next release of WP *g*… maybe it’ll be fixed there.

    I am having the same problem. I’ve searched for solutions and read the code in wp-admin/link-parse-opml.php, scratched my head, nothing works. I can’t even find this error code (invalid document end) in the php.net xml parsing error codes.

    Glad to see it’s not just me.

    I just exported my Bloglines feed and tried to import it. It also fails, with the same error message.

    I compared the code in the link-parse-opml.php files from 2.0.7 and 2.1, and there’s some minor changes in formatting but nothing else. I then swapped the 2.0.7 version for the current version in 2.1, and the uploads still fail with the same error. So it doesn’t appear that the problem is in that file.

    It looks like this might be relevant:
    php and XHTML discussion

    It appears that valid XHTML is having problems with xml tags because they look like php tags:
    <?xml vs. <?php and php doesn’t require the php. You can simply do this: <? – so xml looks like php to the web browser.

    I think this may be what is breaking the uploads.

    The import will work if you upload it to your server and use the HTTP method to then access the file. This may be because the page is not being sent/parsed as XML when the upload method is used.

    I see, using this procedure (Uploading and importing via http) works fine but a bit “uncomfortable”.

    It’s a work-around till there would be a solution for the direct upload from local file. Thanx a lot, you made my day 🙂

    Same problems, so I tried the suggested workaround and got this:

    *

    Importing…

    Fatal error: Cannot redeclare startelement() (previously declared in /home/bluehole/public_html/bluehole/wp/wp-content/plugins/blogger-rss-import.php:99) in /home/bluehole/public_html/bluehole/wp/wp-admin/link-parse-opml.php on line 21

    Any ideas?

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘XML-Error, OPML-Import’ is closed to new replies.