'xml declaration not at start of external entity' error from rss feed (5 posts)

  1. galego
    Posted 9 years ago #

    I've seen a number of related, almost the same topics on this. I have wordpress freshly installed (v. 2.0.3).

    Can see for yourself ...

    No plugins (that's what seemed to cause it in most people's cases) except for the database backup turned on (well, that's not even on now). If I save the source, and remove the leading line and view it in the browser, then it's OK. Any ideas how to get rid of the leading line or how it's getting in there? Anyone else have this issue with 2.0.3? Searches have only drummed up similar problems. Most solutions appear to be plugin related.

  2. lcf
    Posted 8 years ago #

    check wp-rss2.php source code to see if any extra line break in the head?

  3. andhunt
    Posted 8 years ago #

    I've had the same problem, I looked in the source but i can't find anything. It seems that something is inserting 4 blank lines at the start of the document, what could be the causes? (I've tried removing the line breakers (square O's) but that doesn't do anything)

  4. issa
    Posted 8 years ago #

    hello. i had the same problem and i solved it like this:

    1) check your index.php at the FTP root of your blog
    2) erase the blank lines, so the file starts with <?php
    3) validate your feed to check if everything's alright: http://feedvalidator.org/

    efectively, the blank lines mess up with the validation of the feed.

  5. issa
    Posted 8 years ago #

    btw, check for blank lines in any template or php file you've edited.

Topic Closed

This topic has been closed to new replies.

About this Topic