Support » Installing WordPress » XCode Error when trying to install on MacOS

  • joylt19

    (@joylt19)


    Hello – I’m trying to install WordPress on my Mac, and I’m following instructions in the readme file. When in click on install.php, I get an XCode pop up message: “No macOS SDK was found, but Xcode requires a macOS SDK. You may have an incomplete or damaged installation of Xcode.”

    Any advice? Thank you!

Viewing 1 replies (of 1 total)
  • I don’t know what “readme file” you’re reading that says you should click on install.php, but this file is supposed to be run from a web server and open in your browser like any website.

    And I don’t use a Mac, but my understanding is that XCode is supposed to be an IDE. This tells me when you clicked on install.php, XCode was opening the file for editing. Which is not what you want.

    WordPress should have nothing to do with XCode to run.

    To run WordPress on your local computer, you need a web server (like Apache, Nginx, etc), MySQL database server, and the PHP runtime.

    You may install these individually (of you know what you’re doing!), use an all-in-one desktop server package like MAMP, or use a WordPress-specific local server appliance like Local by Flywheel or DeskServer from ServerPress.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.