Support » Fixing WordPress » xc_fcntl_lock errno:9 with XCache enabled

  • All of a sudden I started getting sporadic HTTP 503 errors on my WordPress blog, as well as this error:

    Fatal Error xc_fcntl_lock errno:9 in Unknown on line 0

    These appeared both on user pages and admin pages, but never consistently.

    The problem was made to go away by disabling XCache in my .htaccess file.

    Anyone know anything about this? I tried looking on the XCache site but it just returns 503 errors on all the pages 😯

Viewing 8 replies - 1 through 8 (of 8 total)
  • Can you post your site URL?

    is one of the sites. I have disabled XCache, so you won’t see any errors. And when XCache is enabled, you can go for some time without seeing an error, and then there would be a cluster of them. For some reason, the most likely thing to fail is posting an article through the xmlrpc api using Microsoft Live Write.

    I run WP SuperCache also, so the PHP doesn’t get run some of the time. Usually the error occurs to a user posting a comment. They get the error, but the comment posts anyway.

    The plug-ins on that site are:

    Enhanced WP-ContactForm
    Limit Login Attempts
    TPC! Memory Usage
    WordPress Database Backup
    WP Photo Album Plus
    WP Super Cache (not activated on this particular site)
    Hello Dolly (not activated)

    All are the latest version and the theme is Twenty Ten

    If removing the plugin solved the issue, what other problems do you see in your site?

    I don’t see any problems with my site except that it uses 5-7x more memory when XCache is disabled.

    I don’t have any XCache plug-in in my WordPress installation; it’s something my hosting company apparently does server wide.

    Any time my site is messed up for 3 days, I want to understand what the problem is, and I would hope eventually not to need a custom .htaccess in the long term because various plug-ins play with that and it’s an accident waiting to happen again.

    I use WP Super Cache on one of the blogs that get errors and I don’t use it on another that got errors.

    If you are suggesting that I use these plug-ins instead of XCache, I would just note that the blog that uses WP SuperCache is heavily commented (I have 185,000 comments on it), so pages have to be re-generated a lot.

    Somehow XCache got re-enabled at my site and the problem came back. I’d really like some feedback on what the problem might be.

    BTW, this installation uses the LightSpeed server. In the most recent incarnation, the error message changed a little:

    PHP Fatal error: xc_fcntl_lock failed
    errno:9 in …/wp-load.php on line 29 (different line number)

    And I’m running a later version of WordPress (3.8.1). PHP is version 5.3.28.

    FWIW, line 29 of wp-load.php is:

    require_once( ABSPATH . 'wp-config.php' );

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘xc_fcntl_lock errno:9 with XCache enabled’ is closed to new replies.