WordPress.org

Support

Support » Installation » XAMPP WordPress => Error establishing a database connection

XAMPP WordPress => Error establishing a database connection

    1. <?php
      // ** MySQL settings ** //
      define(‘word press’, ‘wordpress’); // The name of the database
      define(‘admin’, ‘username’); // Your MySQL username
      define(‘952187’, ‘password’); // …and password
      define(”, ‘localhost’); // 99% chance you won’t need to change this value

      // You can have multiple installations in one database if you give each a unique prefix
      $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

      // Change this to localize WordPress. A corresponding MO file for the
      // chosen language must be installed to wp-includes/languages.
      // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
      // to enable German language support.
      define (‘WPLANG’, ”);

      /* That’s all, stop editing! Happy blogging. */

      define(‘ABSPATH’, dirname(__FILE__).’/’);
      require_once(ABSPATH.’wp-settings.php’);
      ?>

    This is the problem.

    I use
    xampp& mysql and localhost and no acess to real web

    my mysql account password is 952187, my username is admin
    dbname – wordpress
    This is a developing stage.

    __________________________________________________
    Code is a poetry, written in language, that is equaly unacessable to all of us.
    Unknown Freethinker

Viewing 4 replies - 1 through 4 (of 4 total)
  • Les Bessant

    @lesbessant

    keeper of the Tiggers

    The database settings should be:

    define('DB_NAME', 'wordpress');
    define('DB_USER', 'admin');
    define('DB_PASSWORD', '952187');
    define('DB_HOST', 'localhost'); 

    Thanks
    I’ll try

    I am having the same issue my error is:

    Parse error: syntax error, unexpected T_STRING in /home/illusive/public_html/blog/wp-config.php on line 6

    Here is the actual text of wp-config.php”
    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘illusive_blog’); // The name of the database
    define(‘DB_USER’, ‘illusive_susan’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘[moderated]‘); // …and password
    define(‘DB_Host’, ‘illusive_illusive’); // 99% chance you won’t need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    Link to site where I am installing wp:
    http://www.illusivelife.com/blog
    to install the script:
    http://www.illusivelife.com/blog/wp-admin/install.php

    Any clues?

    Thanks. I installed it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘XAMPP WordPress => Error establishing a database connection’ is closed to new replies.
Skip to toolbar